summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Müller2018-12-17 12:59:56 +0100
committerThorsten Müller2018-12-17 12:59:56 +0100
commit8872c1dec93e126813a16a5c64d55d1112090a8d (patch)
treea67f0133d76a8054095a0d7e157bb50e467ef2dd
downloadaur-8872c1dec93e126813a16a5c64d55d1112090a8d.tar.gz
samhain client version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rw-r--r--samhain.install6
-rw-r--r--samhain.service10
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40149e02f76d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = samhain-client
+ pkgdesc = file integrity / intrusion detection system
+ pkgver = 4.3.1
+ pkgrel = 1
+ url = http://www.la-samhna.de/
+ install = samhain.install
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ source = http://www.la-samhna.de/samhain/samhain-current.tar.gz
+ source = samhain.service
+ validpgpkeys = EF6CEF54701A0AFDB86AF4C31AAD26C80F571F6C
+ sha256sums = d4dcedc6bc579c935de7972d23675e94654391c3a1bd19c06ec38e57f7faf1f2
+ sha256sums = 7e53bee6bb9ba15db6e741ed3520491c747e57bb58ffc0da6c5d7e235ac720c9
+
+pkgname = samhain-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef73d3d2b53e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Thorsten Mueller <info@thorko.de>
+# Contributor:
+
+pkgname=samhain-client
+pkgver=4.3.1
+pkgrel=1
+pkgdesc="file integrity / intrusion detection system"
+arch=(x86_64 armv7h)
+url="http://www.la-samhna.de/"
+license=('GPL')
+install=samhain.install
+source=("http://www.la-samhna.de/samhain/samhain-current.tar.gz"
+ "samhain.service")
+sha256sums=('d4dcedc6bc579c935de7972d23675e94654391c3a1bd19c06ec38e57f7faf1f2'
+ '7e53bee6bb9ba15db6e741ed3520491c747e57bb58ffc0da6c5d7e235ac720c9')
+validpgpkeys=('EF6CEF54701A0AFDB86AF4C31AAD26C80F571F6C')
+
+build() {
+ echo "Note: If the GPG verification fails, import the Samhain GPG key: http://www.la-samhna.de/samhain/s_rkey.html"
+ gpg --verify samhain-${pkgver}.tar.gz.asc samhain-${pkgver}.tar.gz
+ tar -zxvf samhain-${pkgver}.tar.gz
+ cd "samhain-${pkgver}"
+ # see samhain documentation, lots of other options available. e.g. use --enable-network=server to run in server mode.
+ #./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin
+ ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin --enable-network=client
+ make
+}
+
+package() {
+ cd "samhain-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+ chmod 755 ${pkgdir}/usr/bin/samhain_setpwd
+ chmod 755 ${pkgdir}/usr/bin/samhain
+ chmod 644 ${pkgdir}/etc/samhainrc
+ install -m755 -d "${pkgdir}/usr/lib/systemd/system"
+ install -m644 "${srcdir}/samhain.service" "${pkgdir}/usr/lib/systemd/system/samhain.service"
+ rmdir ${pkgdir}/run
+ rm -rf ${pkgdir}/var/log
+}
diff --git a/samhain.install b/samhain.install
new file mode 100644
index 000000000000..6c08e223f66e
--- /dev/null
+++ b/samhain.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "NOTE: samhain works by comparing the present state of the filesystem agains a"
+ echo "baseline database. If this is the first time that you are using samhain you"
+ echo "will need to perform the initialization (i.e. create the baseline database)"
+ echo "type the following command: samhain -t init"
+}
diff --git a/samhain.service b/samhain.service
new file mode 100644
index 000000000000..711b987726e0
--- /dev/null
+++ b/samhain.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Samhain HIDS
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/samhain start
+ExecStop=/usr/bin/samhain stop
+
+[Install]
+WantedBy=multi-user.target