summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Pirogov2018-12-07 23:32:29 +0100
committerAnton Pirogov2018-12-07 23:32:29 +0100
commit8877be99420cc5e06da68e2f13b8ccc62f3b6140 (patch)
tree4d074fcd5af57fbc715c6d03967c5017b9cd2833
parentbf5e902d2f3d353cca65c6a90403faef9c30489a (diff)
downloadaur-8877be99420cc5e06da68e2f13b8ccc62f3b6140.tar.gz
switched from cabal to stack
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da9c5836ac25..095624eba4a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,25 +9,24 @@ license=('MIT')
arch=('i686' 'x86_64')
depends=('xdotool' 'xorg-xmodmap')
-makedepends=('git' 'ghc' 'cabal-install')
+makedepends=('git') #this also needs stack, but usually stack is installed locally
source=("git+https://github.com/apirogov/${pkgname}.git")
md5sums=('SKIP')
# PKGBUILD functions
+prepare() {
+ cd ${srcdir}/${pkgname}
+ stack install --only-snapshot
+
+}
build() {
cd ${srcdir}/${pkgname}
-
- cabal update
-
- cabal sandbox init
- cabal install --only-dependencies
- cabal configure -O --prefix=/usr
- cabal build
+ stack build
}
package() {
cd ${srcdir}/${pkgname}
- cabal copy --destdir=${pkgdir}
+ stack install --local-bin-path=${pkgdir}
}