summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lange2022-03-05 21:21:11 +0100
committerThomas Lange2022-03-05 21:21:11 +0100
commit88855e8df01c62cd283973959ce45272a73c0b9d (patch)
tree87817fb074c05336b362e5ce703492118d8ee93b
parent83459ef8150818229c115169f2d2a17fbd1d309a (diff)
downloadaur-88855e8df01c62cd283973959ce45272a73c0b9d.tar.gz
Use upstream fix for FFmpeg 5.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dd1a51382c7..08213b6eeff0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = audacious-plugins-gtk3
pkgdesc = Plugins for Audacious
pkgver = 4.1
- pkgrel = 3
+ pkgrel = 4
url = https://audacious-media-player.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index aff761de4390..37712af250ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=audacious-plugins
pkgname=$_pkgname-gtk3
pkgver=4.1
-pkgrel=3
+pkgrel=4
pkgdesc="Plugins for Audacious"
arch=('i686' 'x86_64')
url="https://audacious-media-player.org/"
@@ -25,15 +25,16 @@ sha256sums=('SKIP')
prepare() {
cd "$_pkgname"
+
+ # Fix build with FFmpeg 5.0
+ git cherry-pick -n f60beb400eeb1e4778bbfd738bc4a4ccef3de539
+
autoreconf -I m4
}
build() {
cd "$_pkgname"
- # Work around build failure due to FFmpeg 5.0 APIs returning const pointers
- CXXFLAGS+=' -fpermissive'
-
./configure \
--prefix=/usr \
--disable-qt