summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTommy Jerry Mairo2016-04-22 17:33:15 +0800
committerTommy Jerry Mairo2016-04-22 17:33:15 +0800
commit889b599a3f19ab4ded0e5c9c76bd00c422bb1b84 (patch)
treebc223c4012ea7d40dbd63dcdf5dd65b34b049281
downloadaur-889b599a3f19ab4ded0e5c9c76bd00c422bb1b84.tar.gz
Creat this repo
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--rtl8192eu.install3
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9aeaa43815b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rtl8192eu
+ pkgdesc = Driver for the Realtek8192eu chipset
+ pkgver = 4.3.1.1
+ pkgrel = 1
+ url = https://github.com/Mange/rtl8192eu-linux-driver
+ install = rtl8192eu.install
+ arch = x86_64
+ license = GPL
+ makedepends = linux-headers
+ makedepends = git
+ depends = dkms
+ source = git+https://github.com/Mange/rtl8192eu-linux-driver.git#commit=a322c84595b526fc27b979109998188b4ff8042e
+ md5sums = SKIP
+
+pkgname = rtl8192eu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad4e6a1cc7d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: TJM <tommy.mairo@gmail.com>
+pkgname=rtl8192eu
+pkgver=4.3.1.1
+pkgrel=1
+pkgdesc="Driver for the Realtek8192eu chipset"
+arch=("x86_64")
+url="https://github.com/Mange/rtl8192eu-linux-driver"
+license=('GPL')
+depends=("dkms")
+makedepends=('linux-headers' 'git')
+source=("git+https://github.com/Mange/rtl8192eu-linux-driver.git#commit=a322c84595b526fc27b979109998188b4ff8042e")
+install=${pkgname}.install
+md5sums=('SKIP')
+
+build() {
+
+ cd "rtl8192eu-linux-driver"
+ make
+}
+prepare(){
+ cd "rtl8192eu-linux-driver"
+ sed -i '1341i\ install -d $(MODDESTDIR)' Makefile
+ sed -i 's/$(MODDESTDIR)/$(DESTDIR)$(MODDESTDIR)/g' Makefile
+}
+package() {
+ cd "rtl8192eu-linux-driver"
+ make DESTDIR="$pkgdir/usr/" install
+}
diff --git a/rtl8192eu.install b/rtl8192eu.install
new file mode 100644
index 000000000000..639e2832a847
--- /dev/null
+++ b/rtl8192eu.install
@@ -0,0 +1,3 @@
+post_install(){
+ /sbin/depmod -a `uname -r`
+}