summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-11-22 17:27:26 +0100
committerMuflone2015-11-22 17:37:07 +0100
commit88b49fa378958c095278e5dda46ae326eea23559 (patch)
tree8b09cd95777c736f20b8f68fd344e7ff1452892d
downloadaur-88b49fa378958c095278e5dda46ae326eea23559.tar.gz
New package textdataparser-git 0.1.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--textdataparser-git.install12
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af637c138f79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = textdataparser-git
+ pkgdesc = Trace the activities of an external application
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://www.muflone.com/textdataparser/
+ install = textdataparser-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gtk3
+ depends = gobject-introspection
+ depends = python2-xdg
+ depends = python2-gobject
+ depends = gtk-update-icon-cache
+ provides = textdataparser
+ conflicts = textdataparser
+ source = git+https://github.com/muflone/textdataparser.git
+ sha256sums = SKIP
+
+pkgname = textdataparser-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fc686f776dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=textdataparser-git
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Trace the activities of an external application"
+url="http://www.muflone.com/textdataparser/"
+arch=('any')
+license=('GPL2')
+depends=('gtk3' 'gobject-introspection' 'python2-xdg' 'python2-gobject' 'gtk-update-icon-cache')
+makedepends=('git')
+provides=('textdataparser')
+conflicts=('textdataparser')
+source=("git+https://github.com/muflone/textdataparser.git")
+sha256sums=('SKIP')
+install="${pkgname}.install"
+
+pkgver() {
+ cd "${pkgname%-*}"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${pkgname%-*}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname%-*}"
+ python2 setup.py install --optimize=1 --root "${pkgdir}"
+}
+
diff --git a/textdataparser-git.install b/textdataparser-git.install
new file mode 100644
index 000000000000..736528a49255
--- /dev/null
+++ b/textdataparser-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor/
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+