summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-07-08 14:24:49 +0800
committerUniversebenzene2021-07-08 14:24:49 +0800
commit88d06fae239f5d6aa8302f334ea4250ec54fd026 (patch)
tree22abd7265d3fab6d21f457d500dc2be15c59600d
parent33cc0978c7b5137d7cc4d46e454681176dbf4780 (diff)
downloadaur-88d06fae239f5d6aa8302f334ea4250ec54fd026.tar.gz
Update to version 1.7.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be75aa2a8a66..2e1fd6a64ca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-galpy
pkgdesc = Galactic Dynamics in python
- pkgver = 1.6.0.post0
+ pkgver = 1.7.0
pkgrel = 1
url = http://galpy.readthedocs.io
arch = i686
@@ -9,8 +9,8 @@ pkgbase = python-galpy
makedepends = python-setuptools
makedepends = python2-setuptools
makedepends = gsl
- source = https://files.pythonhosted.org/packages/source/g/galpy/galpy-1.6.0.post0.tar.gz
- md5sums = 7a8f977098dbb1c7450c39d4b4d23ebb
+ source = https://files.pythonhosted.org/packages/source/g/galpy/galpy-1.7.0.tar.gz
+ md5sums = e57fa62ff8cd6356e522d06eae9aafd9
pkgname = python-galpy
depends = python-scipy
@@ -37,4 +37,3 @@ pkgname = python2-galpy
optdepends = python2-astroquery: For the Orbit.from_name initialization method
optdepends = python2-numexpr: For or plotting arbitrary expressions of Orbit quantities
optdepends = python2-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential
-
diff --git a/PKGBUILD b/PKGBUILD
index 03e35d0dd0d3..3598cbcd1c8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-galpy
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=1.6.0.post0
+pkgver=1.7.0
pkgrel=1
pkgdesc="Galactic Dynamics in python"
arch=('i686' 'x86_64')
@@ -15,12 +15,13 @@ makedepends=('python-setuptools' 'python2-setuptools' 'gsl')
# 'python-matplotlib'
## 'python2-matplotlib'
# 'python-future'
-# python-scipy)
+# 'python-scipy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('7a8f977098dbb1c7450c39d4b4d23ebb')
+md5sums=('e57fa62ff8cd6356e522d06eae9aafd9')
prepare() {
cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
@@ -37,12 +38,12 @@ build() {
}
#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-# python setup.py test
-# pytest
-
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py test
+# cd ${srcdir}/${_pyname}-${pkgver}
+## python setup.py test
+# pytest "build/lib.linux-${CARCH}-${_pyver}"
+#
+## cd ${srcdir}/${_pyname}-${pkgver}-py2
+## python2 setup.py test
#}
package_python2-galpy() {