summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-07-13 11:45:53 -0600
committerMark Wagie2021-07-13 11:45:53 -0600
commit88dbf9ce6979e8b042f3cc13dcd5426052c3fbb3 (patch)
tree0928f383b420974b1a33648e47a035c9e821e6bf
parent1c171026ea535f04ff3d84dc0f6c8be7abece01f (diff)
downloadaur-88dbf9ce6979e8b042f3cc13dcd5426052c3fbb3.tar.gz
various improvments & fixes
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD25
3 files changed, 19 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee78535a8a4e..6b66f9f358e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = hidpi-daemon
pkgdesc = Daemon to manage HiDPI and LoDPI monitors on X
pkgver = 18.04.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pop-os/hidpi-daemon
arch = any
- license = GPL
+ license = GPL2
depends = acpid
depends = python>=3.6
depends = python-pydbus
depends = python-gobject
depends = python-xlib
depends = libnotify
- conflicts = system76-driver<17.10.32
source = https://github.com/pop-os/hidpi-daemon/archive/18.04.6.tar.gz
- sha1sums = f7e33263acb34b624b80c6e680ac491f722738d0
+ sha256sums = ecb6135128c84dd37499c642d017ee663d7e91479806b8d67d1452fb1769c370
pkgname = hidpi-daemon
-
diff --git a/.gitignore b/.gitignore
index 9fae8a7b4224..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
-*.tar.xz
-*.tar.gz
-*.tar.zst
-/pkg
-/src
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index a2659948fe01..6622b07d5cd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=hidpi-daemon
pkgver=18.04.6
-pkgrel=1
+pkgrel=2
pkgdesc="Daemon to manage HiDPI and LoDPI monitors on X"
arch=('any')
url="https://github.com/pop-os/hidpi-daemon"
-license=('GPL')
+license=('GPL2')
depends=(
'acpid'
'python>=3.6'
@@ -14,19 +14,15 @@ depends=(
'python-gobject'
'python-xlib'
'libnotify')
-makepdepends=(
- 'python-pyflakes')
-conflicts=('system76-driver<17.10.32')
-source=(
- "https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz")
-sha1sums=(
- 'f7e33263acb34b624b80c6e680ac491f722738d0')
+source=("https://github.com/pop-os/hidpi-daemon/archive/${pkgver}.tar.gz")
+sha256sums=('ecb6135128c84dd37499c642d017ee663d7e91479806b8d67d1452fb1769c370')
package() {
cd ${srcdir}/${pkgname}-${pkgver}
# Build and install base package
- python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
+ export PYTHONHASHSEED=0
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
# Install daemons and executables
install -m755 -D hidpi-daemon ${pkgdir}/usr/lib/${pkgname}/hidpi-daemon
@@ -40,8 +36,5 @@ package() {
install -m644 -D com.system76.hidpi.gschema.xml ${pkgdir}/usr/share/glib-2.0/schemas/com.system76.hidpi.gschema.xml
# Create empty /var/lib package directory
- mkdir -p ${pkgdir}/var/lib/${pkgname}
-
- # Clean up
- rm -rf ${pkgdir}/usr/lib/python*/site-packages/hidpidaemon/{__pycache__,tests}
+ install -d ${pkgdir}/var/lib/${pkgname}
}