summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Bädorf2020-09-14 14:46:57 +0200
committerBenjamin Bädorf2020-09-14 14:46:57 +0200
commit88ef40dbc8ddc9b4d7ec7b51b5bdc6d2463d29c6 (patch)
tree119ceb584c64e5502fb848aee3acb010b7184ab6
downloadaur-88ef40dbc8ddc9b4d7ec7b51b5bdc6d2463d29c6.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e858a0da23d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tmpmail-git
+ pkgdesc = A temporary email right from your terminal
+ pkgver = 2.g177dcc3
+ pkgrel = 1
+ url = https://github.com/sdushantha/tmpmail
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = w3m
+ depends = curl
+ depends = jq
+ source = tmpmail::git+https://github.com/sdushantha/tmpmail.git
+ md5sums = SKIP
+
+pkgname = tmpmail-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a980af00afe5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..995b668559c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Benjamin Bädorf <aur at benjaminbaedorf dot eu>
+# Maintainer: Siddarth Dushantha <siddarth dot dushanta at gmail dot com>
+
+pkgname=tmpmail-git
+_pkgname=tmpmail
+pkgver=2.g177dcc3
+pkgrel=1
+pkgdesc="A temporary email right from your terminal"
+arch=('any')
+url="https://github.com/sdushantha/tmpmail"
+license=('MIT')
+makedepends=('git')
+depends=('w3m' 'curl' 'jq')
+provides=()
+conflicts=()
+source=("$_pkgname::git+https://github.com/sdushantha/tmpmail.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ chmod +x ./tmpmail
+ mkdir -p "$pkgdir/usr/bin"
+ cp ./tmpmail "$pkgdir/usr/bin"
+}