summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-11-21 22:27:08 +0100
committerAleksandar Trifunovic2018-11-21 22:27:08 +0100
commit89030d0c3fdd3584f53bdc7190740533cdbc2dd2 (patch)
tree6a4e307f0f9b1bed9e571c268e6e56e8646767c8
parent81fcaed998f4ae15118d534ad09d6f8aa089bce1 (diff)
downloadaur-89030d0c3fdd3584f53bdc7190740533cdbc2dd2.tar.gz
3.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 906b45ed83fd..1a2d03ae00fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = valhalla
pkgdesc = Routing engine for OpenStreetMap.
- pkgver = 2.6.3
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/valhalla/valhalla
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = valhalla
depends = python
depends = lua
depends = libspatialite
- source = https://github.com/valhalla/valhalla/archive/2.6.3.tar.gz
- sha256sums = 42db5bc48409983b4ccfd0a152347016e0a6dd6aa1313b9ba6896d2346df9d0b
+ source = https://github.com/valhalla/valhalla/archive/3.0.0.tar.gz
+ sha256sums = 84807a69b8e66f6edc47c14b4229f76eacbdf4883cf8d1d38e68c6ef3b0ecb1b
pkgname = valhalla
diff --git a/PKGBUILD b/PKGBUILD
index a6b4cc0c06f6..d3f13a9213b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aleksandar Trifunović <akstrfn@gmail.com>
pkgname=valhalla
-pkgver=2.6.3
+pkgver=3.0.0
pkgrel=1
pkgdesc="Routing engine for OpenStreetMap."
arch=('x86_64')
@@ -10,15 +10,19 @@ license=('custom:MIT')
depends=('prime_server' 'boost-libs' 'protobuf' 'python' 'lua' 'libspatialite')
makedepends=('cmake' 'git' 'vim' 'jq' 'boost' 'rapidjson')
source=("${url}/archive/$pkgver.tar.gz")
-sha256sums=('42db5bc48409983b4ccfd0a152347016e0a6dd6aa1313b9ba6896d2346df9d0b')
+sha256sums=('84807a69b8e66f6edc47c14b4229f76eacbdf4883cf8d1d38e68c6ef3b0ecb1b')
prepare() {
cd "$pkgname-$pkgver"
git clone https://github.com/scrosby/OSM-binary third_party/OSM-binary
git clone https://github.com/valhalla/osmlr-tile-spec third_party/OSMLR
+ git clone https://github.com/tronkko/dirent third_party/dirent
+ git clone https://github.com/HowardHinnant/date third_party/date
- cd "$srcdir/$pkgname-$pkgver"/third_party/OSM-binary && git checkout 4e32fa2
- cd "$srcdir/$pkgname-$pkgver"/third_party/OSMLR && git checkout ae07abe
+ cd "$srcdir/$pkgname-$pkgver"/third_party/OSM-binary && git checkout 4e32fa2 -q
+ cd "$srcdir/$pkgname-$pkgver"/third_party/OSMLR && git checkout 0f4000e -q
+ cd "$srcdir/$pkgname-$pkgver"/third_party/dirent && git checkout 287ba92 -q
+ cd "$srcdir/$pkgname-$pkgver"/third_party/date && git checkout 3e82a52 -q
cd "$srcdir/$pkgname-$pkgver"
@@ -27,6 +31,9 @@ prepare() {
# https://groups.google.com/forum/#!topic/spatialite-users/YXnofHixXsM
# https://github.com/valhalla/valhalla/issues/354
sed -i 's/mod_spatialite/\/usr\/lib\/mod_spatialite/' src/mjolnir/admin.cc
+
+ # https://github.com/valhalla/valhalla/issues/1570
+ sed -i 's/GeometryFactory::unique_ptr gf = GeometryFactory::create();/GeometryFactory::Ptr gf = GeometryFactory::create();/' src/mjolnir/valhalla_build_admins.cc
}
build() {
@@ -40,7 +47,10 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_DATA_TOOLS=On \
-DENABLE_PYTHON_BINDINGS=On \
+ -DENABLE_NODE_BINDINGS=Off \
-DENABLE_SERVICES=On \
+ -DENABLE_CCACHE=Off \
+ -DENABLE_HTTP=On \
-DBUILD_SHARED_LIBS=On
cmake --build build