summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-07-12 20:30:20 +0200
committerFabioLolix2021-07-12 20:30:20 +0200
commit8904a32f6595892bae3a963e55ad5e75bea2f165 (patch)
treebb9f7b0be7fc25e935f4214082a86e238b29451e
parentb4d84443f55da9ac92bb267e34d533d03418809e (diff)
downloadaur-8904a32f6595892bae3a963e55ad5e75bea2f165.tar.gz
Switch to default branch()
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
2 files changed, 37 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db22934fc67f..e96b5b53fec0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vnote-git
pkgdesc = A Vim-inspired note-taking application, especially for Markdown.
- pkgver = 2.10.r0.gde753706
- pkgrel = 2
+ pkgver = 3.4.0.r4.c13d1803
+ pkgrel = 1
url = https://vnotex.github.io/vnote/en_us/
arch = x86_64
arch = i686
@@ -9,14 +9,18 @@ pkgbase = vnote-git
arch = armv6h
arch = armv7h
arch = aarch64
- license = MIT
+ license = GPL3
makedepends = git
depends = qt5-base
depends = qt5-webengine
depends = qt5-svg
- source = git+https://github.com/tamlok/vnote.git#branch=vnote2.0
- source = git+https://github.com/chjj/marked.git
- source = git+https://github.com/tamlok/hoedown.git
+ source = git+https://github.com/vnotex/vnote.git
+ source = vnotex-vtextedit::git+https://github.com/vnotex/vtextedit
+ source = vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting
+ source = vnotex-hunspell::git+https://github.com/vnotex/hunspell
+ source = vnotex-sonnet::git+https://github.com/vnotex/sonnet
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index af7ba73109f0..c1ccabd3a23b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,56 @@
# Contributor: erk <v at erk dot io>
pkgname=vnote-git
-pkgver=2.10.r0.gde753706
-pkgrel=2
+pkgver=3.4.0.r4.c13d1803
+pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url='https://vnotex.github.io/vnote/en_us/'
-license=(MIT)
+license=(GPL3)
depends=(qt5-base qt5-webengine qt5-svg)
makedepends=(git)
-source=("git+https://github.com/tamlok/vnote.git#branch=vnote2.0"
- "git+https://github.com/chjj/marked.git"
- "git+https://github.com/tamlok/hoedown.git")
+source=("git+https://github.com/vnotex/vnote.git"
+ "vnotex-vtextedit::git+https://github.com/vnotex/vtextedit"
+ "vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting"
+ "vnotex-hunspell::git+https://github.com/vnotex/hunspell"
+ "vnotex-sonnet::git+https://github.com/vnotex/sonnet")
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${srcdir}/${pkgname%-git}"
+ #printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ TAG=$(git tag --list | tail -n 1 | sed 's/^v//')
+ printf "${TAG}.r%s.%s" "$(git rev-list --count v${TAG}..HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${srcdir}/${pkgname%-git}"
+
+ install -d build
git submodule init
- git config 'submodule.src/utils/marked.url' "${srcdir}/marked"
- git config 'submodule.hoedown.url' "${srcdir}/hoedown"
+ git config 'submodule.libs/vtextedit.url' "${srcdir}/vnotex-vtextedit"
git submodule update
- install -d build
+ cd "libs/vtextedit"
+ git submodule init
+ git config 'submodule.src/libs/syntax-highlighting.url' "${srcdir}/vnotex-syntax-highlighting"
+ git config 'submodule.src/libs/hunspell.url' "${srcdir}/vnotex-hunspell"
+ git config 'submodule.src/libs/sonnet.url' "${srcdir}/vnotex-sonnet"
+ git submodule update
}
build() {
- cd "$srcdir/${pkgname%-git}/build"
- qmake-qt5 ../VNote.pro
+ cd "${srcdir}/${pkgname%-git}/build"
+ qmake-qt5 ../vnote.pro
make
}
package() {
- cd "$srcdir/${pkgname%-git}/build"
+ cd "${srcdir}/${pkgname%-git}/build"
make INSTALL_ROOT="$pkgdir" install
- install -Dm644 "$srcdir/${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}