summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Loher2016-02-12 13:47:29 +0100
committerJohannes Loher2016-02-12 13:47:29 +0100
commit8909cddfcfc9a0d10e55ab53edb43121d45d3758 (patch)
tree8d0591360f0c9d366c5f18f3c2dc16f638074834
downloadaur-8909cddfcfc9a0d10e55ab53edb43121d45d3758.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--ttf-cormorant.install13
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c170312ca6ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Feb 12 12:47:07 UTC 2016
+pkgbase = ttf-cormorant
+ pkgdesc = Cormorant fonts
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://www.behance.net/gallery/28579883/Cormorant-an-open-source-display-font-family
+ install = ttf-cormorant.install
+ arch = any
+ license = custom: OFL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = https://github.com/CatharsisFonts/Cormorant/releases/download/v2.1/Cormorant_Install_v2.1.zip
+ md5sums = c02b278ae3cfad025a33031d90c9eb18
+
+pkgname = ttf-cormorant
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..120c3c724544
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Johannes Loher <johannes dot loher at fg4f dot de>
+
+pkgname=ttf-cormorant
+pkgver=2.1
+pkgrel=1
+pkgdesc="Cormorant fonts"
+arch=('any')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+url='https://www.behance.net/gallery/28579883/Cormorant-an-open-source-display-font-family'
+source=("https://github.com/CatharsisFonts/Cormorant/releases/download/v${pkgver}/Cormorant_Install_v${pkgver}.zip")
+md5sums=('c02b278ae3cfad025a33031d90c9eb18')
+install=$pkgname.install
+license=('custom: OFL')
+
+package() {
+ cd "${srcdir}/Cormorant_Install_v${pkgver}"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ install -m644 "1. TrueType Font Files/"*.ttf "$pkgdir/usr/share/fonts/TTF/"
+
+ install -Dm644 "OFL.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
diff --git a/ttf-cormorant.install b/ttf-cormorant.install
new file mode 100644
index 000000000000..e460db51d613
--- /dev/null
+++ b/ttf-cormorant.install
@@ -0,0 +1,13 @@
+post_install() {
+ fc-cache -s -f > /dev/null
+ mkfontscale usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}