summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNing Sun2023-04-17 22:06:38 +0800
committerNing Sun2023-04-17 22:06:38 +0800
commit8913f55d7bdafb695f22b09148d18e815b4a77ac (patch)
treefe9f3af164ed30e53391305377dbd1b270d8eabc
parent83260712b6c16a5f0ead6fba1efb7407cb8ebd1b (diff)
downloadaur-8913f55d7bdafb695f22b09148d18e815b4a77ac.tar.gz
remove vendor boring deps
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 10 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0994f3484952..065410460b7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = quiche
- pkgdesc = an implementation of the QUIC transport protocol and HTTP/3 as specified by the IETF
+ pkgdesc = an implementation of the QUIC transport protocol and HTTP/2 as specified by the IETF
pkgver = 0.17.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cloudflare/quiche
arch = x86_64
license = custom:BSD
@@ -11,9 +11,7 @@ pkgbase = quiche
makedepends = rust
depends = gcc-libs
source = https://github.com/cloudflare/quiche/archive/0.17.1.tar.gz
- source = git+https://boringssl.googlesource.com/boringssl#commit=f1c75347daa2ea81a941e953f2263e0a4d970c8d
validpgpkeys = 8657ABB260F056B1E5190839D9C4D26D0E604491
sha256sums = 3c427415525da565f726df95021235cdc1c6460aa7d89d1aa3e154cb621d45b4
- sha256sums = SKIP
pkgname = quiche
diff --git a/PKGBUILD b/PKGBUILD
index dfd9e65dede4..e10795a6edc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,22 @@
-# Maintainer: Kasei Wang <kasei@kasei.im>
+# Maintainer: Ning Sun <n@sunng.info>
+# Previous Maintainer: Kasei Wang <kasei@kasei.im>
pkgname=quiche
pkgver=0.17.1
-pkgrel=1
-pkgdesc='an implementation of the QUIC transport protocol and HTTP/3 as specified by the IETF'
+pkgrel=2
+pkgdesc='an implementation of the QUIC transport protocol and HTTP/2 as specified by the IETF'
arch=('x86_64')
url='https://github.com/cloudflare/quiche'
license=('custom:BSD')
depends=('gcc-libs')
makedepends=('cmake' 'git' 'go' 'rust')
-source=("https://github.com/cloudflare/$pkgname/archive/$pkgver.tar.gz"
- "git+https://boringssl.googlesource.com/boringssl#commit=f1c75347daa2ea81a941e953f2263e0a4d970c8d")
-sha256sums=('3c427415525da565f726df95021235cdc1c6460aa7d89d1aa3e154cb621d45b4'
- 'SKIP')
+source=("https://github.com/cloudflare/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('3c427415525da565f726df95021235cdc1c6460aa7d89d1aa3e154cb621d45b4')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491')
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
- cargo fetch --target "$CARCH-unknown-linux-gnu"
- rm -rf quiche/deps/boringssl && ln -s $srcdir/boringssl quiche/deps/boringssl
-}
-
build() {
- cd "$srcdir/$pkgname-$pkgver"
- cargo build --frozen --release --features ffi,pkg-config-meta,qlog
-}
-
-check () {
- cd "$srcdir/$pkgname-$pkgver"
- cargo test --frozen
+ cd "$srcdir/$pkgname-$pkgver/quiche"
+ cargo build --frozen --release --no-default-features --features ffi,pkg-config-meta,qlog,boringssl-boring-crate
}
package() {