summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreiNjel2018-02-03 12:45:21 +0100
committereiNjel2018-02-03 12:45:21 +0100
commit891800a7912ef759a0cc53c32bfce97a97618c34 (patch)
tree16c8f0558fc61c99682b3c92e24a8dafc422a707
downloadaur-891800a7912ef759a0cc53c32bfce97a97618c34.tar.gz
Talend 7.0.1 package for linux
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD55
-rwxr-xr-xtalend1
-rw-r--r--talend.desktop18
-rw-r--r--talend.pngbin0 -> 11748 bytes
5 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edf37642830e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = talend-open-studio-esb
+ pkgdesc = Talend Open Studio for ESB 7.0.1 x86_64
+ pkgver = 7.0.1
+ pkgrel = 1
+ url = https://einjel-frontend.herokuapp.com
+ arch = x86_64
+ license = GPL
+ depends = unzip
+ depends = jdk8-openjdk
+ depends = jre8-openjdk
+ depends = jre8-openjdk-headless
+ optdepends = jdk7-openjdk
+ optdepends = jre7-openjdk
+ optdepends = jre7-openjdk-headless
+ provides = talend
+ conflicts = talend
+ options = !libtool
+ options = !emptydirs
+ source = https://sourceforge.net/projects/talendesb/files/Talend%20Open%20Studio%20for%20ESB/7.0.1M1/TOS_ESB-20171115_1047-V7.0.1M1.zip/download
+ source = talend.desktop
+ source = talend.png
+ source = talend
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = d8a58f5a2c9431c1f0edc36d5fa2a93f42593b063548cc539227c895694737aa
+ sha256sums = SKIP
+
+pkgname = talend-open-studio-esb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ae012f6406f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+#
+# Maintainer: eiNjel <alekw3@gmail.com>
+#
+# available sources https://sourceforge.net/projects/talendesb/
+
+pkgname=talend-open-studio-esb
+_pkgname=talend-open-studio-esb
+pkgver=7.0.1
+pkgrel=1
+talend_date="20171115_1047"
+talend_ver="$pkgver"
+talend_ver+="M"
+talend_ver+="$pkgrel"
+pkgdesc="Talend Open Studio for ESB $pkgver x86_64"
+url="https://einjel-frontend.herokuapp.com"
+
+arch=('x86_64')
+license=('GPL')
+
+depends=('unzip' 'jdk8-openjdk' 'jre8-openjdk' 'jre8-openjdk-headless')
+optdepends=('jdk7-openjdk' 'jre7-openjdk' 'jre7-openjdk-headless')
+
+options=('!libtool' '!emptydirs')
+
+provides=('talend')
+conflicts=('talend')
+
+source=("https://sourceforge.net/projects/talendesb/files/Talend%20Open%20Studio%20for%20ESB/$talend_ver/TOS_ESB-$talend_date-V$talend_ver.zip/download"
+ 'talend.desktop'
+ 'talend.png'
+ 'talend')
+
+sha256sums=('SKIP'
+ 'SKIP'
+ 'd8a58f5a2c9431c1f0edc36d5fa2a93f42593b063548cc539227c895694737aa'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir"/
+}
+
+build() {
+ cd "$srcdir"/
+}
+
+package() {
+ cd "$srcdir"/
+ echo "cd /opt/talend-$pkgver/Studio/ && sh TOS_ESB-linux-gtk-x86.sh" > "$srcdir/talend"
+ echo "Icon=/opt/talend-$pkgver/talend.png" >> "$srcdir/talend.desktop"
+ install -Dm755 "$srcdir/talend.desktop" "$pkgdir/usr/share/applications/talend-$pkgver.desktop"
+ install -Dm755 "$srcdir/talend.png" "$pkgdir/opt/talend-$pkgver/talend.png"
+ install -Dm755 "$srcdir/talend" "$pkgdir/usr/bin/talend"
+ mv "$srcdir/download" "$pkgdir/opt/talend-$pkgver/download.zip"
+ cd "$pkgdir/opt/talend-$pkgver/" && unzip download.zip && rm download.zip
+}
diff --git a/talend b/talend
new file mode 100755
index 000000000000..f57e39b1b722
--- /dev/null
+++ b/talend
@@ -0,0 +1 @@
+cd /opt/talend-7.0.1/Studio/ && sh TOS_ESB-linux-gtk-x86.sh
diff --git a/talend.desktop b/talend.desktop
new file mode 100644
index 000000000000..6d1d4df3f14d
--- /dev/null
+++ b/talend.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=7.0.1
+Type=Application
+Terminal=false
+Exec=/usr/bin/talend
+Name=Talend ESB 7.0.1
+Comment=Talend ESB
+Categories=GNOME;KDE;Qt;LXQt;System;Accessories;
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
+Icon=/opt/talend-7.0.1/talend.png
diff --git a/talend.png b/talend.png
new file mode 100644
index 000000000000..baf59c148c3c
--- /dev/null
+++ b/talend.png
Binary files differ