summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrx862021-04-02 21:20:22 +0800
committerbrx862021-04-02 21:20:22 +0800
commit892288ba48fe8637790f9e86647d3cf2f953eb3c (patch)
tree987781d80c48e6483fb260b6a82bf7660242475f
downloadaur-892288ba48fe8637790f9e86647d3cf2f953eb3c.tar.gz
A Strategy War Flash Game
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c254111b3d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = age-of-war-2
+ pkgdesc = A Strategy War Flash Game
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://armorgames.com/user/Louissi
+ arch = x86_64
+ license = custom
+ depends = flashplayer-standalone
+ source = https://aya1.xyz/https://github.com/Brx86/yun/releases/download/2/age-of-war-2.tar.gz
+ md5sums = 5fcce3761a98764d7a34812f695f5f23
+
+pkgname = age-of-war-2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67b5a9cbc98c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ayatale <ayatale@qq.com>
+
+pkgname=age-of-war-2
+pkgver=2.0
+pkgrel=1
+pkgdesc="A Strategy War Flash Game"
+arch=('x86_64')
+url="https://armorgames.com/user/Louissi"
+license=('custom')
+depends=('flashplayer-standalone')
+source=('https://aya1.xyz/https://github.com/Brx86/yun/releases/download/2/age-of-war-2.tar.gz')
+md5sums=('5fcce3761a98764d7a34812f695f5f23')
+noextract=()
+
+prepare() {
+ mkdir "$pkgname-$pkgver"
+ cp -r opt "$pkgname-$pkgver"/opt
+ cp -r usr "$pkgname-$pkgver"/usr
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cp -r opt ${pkgdir}
+ cp -r usr ${pkgdir}
+}