summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2022-03-14 20:29:28 +0200
committerPekka Ristola2022-03-14 20:29:28 +0200
commit8932aa17ce1bedfd4a7e90e8218af8973fec2632 (patch)
tree88e9f62285cf12271b1dfd47afc3af0a00f985cd
parentc662e817cd69a338b8425fceabd0563a6acd8d27 (diff)
downloadaur-8932aa17ce1bedfd4a7e90e8218af8973fec2632.tar.gz
Update to 1.1.2
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 46 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff65e3c08ca6..6814ee065768 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = r-tidyselect
pkgdesc = Select from a Set of Strings
- pkgver = 1.1.1
+ pkgver = 1.1.2
pkgrel = 1
url = https://cran.r-project.org/package=tidyselect
- arch = i686
- arch = x86_64
+ arch = any
license = MIT
- depends = r>=3.2
depends = r-ellipsis
- depends = r-glue>=1.3.0
- depends = r-purrr>=0.3.2
- depends = r-rlang>=0.4.6
- depends = r-vctrs>=0.3.0
+ depends = r-glue
+ depends = r-purrr
+ depends = r-rlang
+ depends = r-vctrs
optdepends = r-covr
optdepends = r-crayon
optdepends = r-dplyr
@@ -21,7 +19,9 @@ pkgbase = r-tidyselect
optdepends = r-testthat
optdepends = r-tibble
optdepends = r-withr
- source = https://cran.r-project.org/src/contrib/tidyselect_1.1.1.tar.gz
- sha256sums = 18eb6a6746196a81ce19ee6cbf1db0c33f494177b97e2419312ef25a00ae486b
+ source = https://cran.r-project.org/src/contrib/tidyselect_1.1.2.tar.gz
+ source = CRAN-MIT-TEMPLATE::https://cran.r-project.org/web/licenses/MIT
+ sha256sums = 0389a3b15417954a30d6d692f6ebdd3d0f318cb94a5c9b05365df2f4ea1d8270
+ sha256sums = e76e4aad5d3d9d606db6f8c460311b6424ebadfce13f5322e9bae9d49cc6090b
pkgname = r-tidyselect
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 8bb584f47aa5..3e11d4288ef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,49 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: frichtlm <frichtlm@gmail.com>
_cranname=tidyselect
-_cranver=1.1.1
+_cranver=1.1.2
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Select from a Set of Strings"
-arch=(i686 x86_64)
+arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
-depends=('r>=3.2' r-ellipsis 'r-glue>=1.3.0' 'r-purrr>=0.3.2' 'r-rlang>=0.4.6' 'r-vctrs>=0.3.0')
-optdepends=(r-covr r-crayon r-dplyr r-knitr r-magrittr r-rmarkdown r-testthat r-tibble r-withr)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('18eb6a6746196a81ce19ee6cbf1db0c33f494177b97e2419312ef25a00ae486b')
+depends=(
+ r-ellipsis
+ r-glue
+ r-purrr
+ r-rlang
+ r-vctrs
+)
+optdepends=(
+ r-covr
+ r-crayon
+ r-dplyr
+ r-knitr
+ r-magrittr
+ r-rmarkdown
+ r-testthat
+ r-tibble
+ r-withr
+)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz"
+ "CRAN-MIT-TEMPLATE::https://cran.r-project.org/web/licenses/MIT")
+sha256sums=('0389a3b15417954a30d6d692f6ebdd3d0f318cb94a5c9b05365df2f4ea1d8270'
+ 'e76e4aad5d3d9d606db6f8c460311b6424ebadfce13f5322e9bae9d49cc6090b')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+
+ install -Dm644 CRAN-MIT-TEMPLATE "${pkgdir}/usr/share/licenses/${pkgname}/MIT"
+ install -Dm644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}