summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott2020-12-06 17:43:35 -0600
committerScott2020-12-06 17:43:35 -0600
commit8972c8ea956ed3029b34da138b81955eba7344ea (patch)
treeafca3fa0146a32f826e40e9e98790d86b09b47b2
downloadaur-8972c8ea956ed3029b34da138b81955eba7344ea.tar.gz
Create package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD45
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25e199398d4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fetchutils
+ pkgdesc = A collection of small (< ~100 LOC) POSIX shell scripts to retrieve system information
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/lptstr/fetchutils
+ arch = x86_64
+ license = MIT
+ makedepends = scdoc
+ depends = bash
+ source = fetchutils::git+https://github.com/lptstr/fetchutils.git
+ md5sums = SKIP
+
+pkgname = fetchutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8224f49d18b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Scott <swlittle At gmail dot (commerical tld)>
+pkgname=fetchutils
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="A collection of small (< ~100 LOC) POSIX shell scripts to retrieve system information"
+arch=("x86_64")
+url="https://github.com/lptstr/fetchutils"
+license=('MIT')
+groups=()
+depends=('bash')
+makedepends=('scdoc')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+BUILDENV+=('!check')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git+https://github.com/lptstr/fetchutils.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname"
+ make
+:q
+ls
+
+
+
+
+
+
+
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir/usr/" install
+}