summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormibbio2015-07-24 12:53:20 +0200
committermibbio2015-07-24 12:53:20 +0200
commit897b60af18d1762067e41e3133b7f57d518e7d9c (patch)
treefcddcc3de515a991cdd74db538dd41ba1529bd74
downloadaur-897b60af18d1762067e41e3133b7f57d518e7d9c.tar.gz
migration to aur4
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
-rw-r--r--netbeans.desktop9
-rw-r--r--netbeans.install40
5 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ce0f0a76311
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = netbeans-cpp
+ pkgdesc = Netbeans IDE development platform - C/C++ only
+ pkgver = 8.0.2
+ pkgrel = 4
+ url = https://netbeans.org/
+ install = netbeans.install
+ arch = i686
+ arch = x86_64
+ license = CDDL
+ depends = java-runtime
+ provides = netbeans
+ conflicts = netbeans
+ replaces = netbeans-cpp-beta
+ options = !strip
+ backup = usr/share/netbeans/etc/netbeans.conf
+ source = http://download.netbeans.org/netbeans/8.0.2/final/bundles/netbeans-8.0.2-cpp-linux.sh
+ source = netbeans.desktop
+ md5sums = 285d6e80e29f81721c30484b46e777c5
+ md5sums = eb9c35b558997f62a52bddad16dba248
+
+pkgname = netbeans-cpp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9a8164c5051b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.zip
+*.sh
+pkg/
+src/
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36abd7714caf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: mibbio <contact at mibbiodev dot de>
+# Contributor: jjacky
+# Contributor: dunningd <duncansdunning at yahoo dot co dot uk>
+# Adapted/copied from netbeans-cpp 6.9.1 (Thanks wimvdh)
+pkgname=netbeans-cpp
+pkgver=8.0.2
+pkgrel=4
+pkgdesc="Netbeans IDE development platform - C/C++ only"
+arch=('i686' 'x86_64')
+url="https://netbeans.org/"
+license=('CDDL')
+depends=('java-runtime')
+provides=('netbeans')
+conflicts=('netbeans')
+replaces=('netbeans-cpp-beta')
+options=('!strip')
+install=netbeans.install
+backup=('usr/share/netbeans/etc/netbeans.conf')
+source=(http://download.netbeans.org/netbeans/$pkgver/final/bundles/netbeans-$pkgver-cpp-linux.sh
+ netbeans.desktop)
+md5sums=('285d6e80e29f81721c30484b46e777c5'
+ 'eb9c35b558997f62a52bddad16dba248')
+
+package() {
+ mkdir -p $pkgdir/usr/share/netbeans
+ /bin/sh $srcdir/../netbeans-$pkgver-cpp-linux.sh --silent --userdir $srcdir -J-Dnb-base.installation.location=$pkgdir/usr/share/netbeans
+ rm $pkgdir/usr/share/netbeans/bin/netbeans.exe
+ rm $pkgdir/usr/share/netbeans/bin/netbeans64.exe
+ rm $pkgdir/usr/share/netbeans/uninstall.sh
+ install -D -m644 $srcdir/netbeans.desktop $pkgdir/usr/share/applications/netbeans.desktop
+ for licensefile in LICENSE.txt THIRDPARTYLICENSE.txt
+ do
+ install -D -m644 $pkgdir/usr/share/netbeans/$licensefile $pkgdir/usr/share/licenses/$pkgname/$licensefile
+ rm $pkgdir/usr/share/netbeans/$licensefile
+ done
+ mkdir -p $pkgdir/usr/bin
+ ln -s /usr/share/netbeans/bin/netbeans $pkgdir/usr/bin/netbeans
+}
diff --git a/netbeans.desktop b/netbeans.desktop
new file mode 100644
index 000000000000..8f22f64956bd
--- /dev/null
+++ b/netbeans.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=NetBeans
+Comment=NetBeans C/C++ IDE
+Icon=/usr/share/netbeans/nb/netbeans.png
+Exec=/usr/share/netbeans/bin/netbeans
+Terminal=false
+Type=Application
+Categories=Development;
+StartupNotify=true
diff --git a/netbeans.install b/netbeans.install
new file mode 100644
index 000000000000..bfe1abe47051
--- /dev/null
+++ b/netbeans.install
@@ -0,0 +1,40 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ update-desktop-database >/dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ update-desktop-database >/dev/null 2>&1
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ update-desktop-database >/dev/null 2>&1
+ /bin/true
+}
+
+op=$1
+shift
+$op $*