summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2015-06-10 14:41:12 +0200
committerÉtienne Deparis2015-06-10 14:41:12 +0200
commit897d57d5852cdfe09bf2dc819aa72ae5cb2af4db (patch)
treeb4dacf3cec002186db8527375e2ec1c6114d145a
downloadaur-897d57d5852cdfe09bf2dc819aa72ae5cb2af4db.tar.gz
New pkgbuild version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--emacs-multiple-cursors.install21
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe56ccd97846
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Wed Jun 10 12:40:46 UTC 2015
+pkgbase = emacs-multiple-cursors
+ pkgdesc = Multiple cursors for Emacs
+ pkgver = 1.3.0
+ pkgrel = 2
+ url = https://github.com/magnars/multiple-cursors.el
+ install = emacs-multiple-cursors.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ source = https://github.com/magnars/multiple-cursors.el/archive/1.3.0.tar.gz
+ md5sums = b60faec04a10f911289cf40828c4ac80
+
+pkgname = emacs-multiple-cursors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fec3bb7be03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+# Maintainer:xgdgsc <xgdgsc@gmail.com>
+
+pkgname=emacs-multiple-cursors
+_pkgname=multiple-cursors
+pkgver=1.3.0
+pkgrel=2
+pkgdesc="Multiple cursors for Emacs"
+arch=('any')
+url="https://github.com/magnars/multiple-cursors.el"
+license=('GPL3')
+install=$pkgname.install
+depends=('emacs')
+source=("https://github.com/magnars/$_pkgname.el/archive/$pkgver.tar.gz")
+md5sums=('b60faec04a10f911289cf40828c4ac80')
+
+build() {
+ cd $srcdir/$_pkgname.el-$pkgver/
+ emacs -batch -f batch-byte-compile *.el
+}
+
+package() {
+ cd $srcdir/$_pkgname.el-$pkgver/
+ install -d -m755 $pkgdir/usr/share/emacs/site-lisp/multiple-cursors
+ install -m644 *.elc $pkgdir/usr/share/emacs/site-lisp/multiple-cursors/
+}
diff --git a/emacs-multiple-cursors.install b/emacs-multiple-cursors.install
new file mode 100644
index 000000000000..9607d56a58ce
--- /dev/null
+++ b/emacs-multiple-cursors.install
@@ -0,0 +1,21 @@
+post_install()
+{
+echo " "
+echo "==================================================================="
+echo " "
+echo "Add the following code to your .emacs:"
+
+echo "(add-to-list 'load-path \"/usr/share/emacs/site-lisp/multiple-cursors\")"
+echo "(require 'multiple-cursors)"
+echo "(global-unset-key (kbd \"C-<down-mouse-1>\"))"
+echo "(global-set-key (kbd \"C-<mouse-1>\") 'mc/add-cursor-on-click)"
+#echo " "
+echo "==================================================================="
+echo " "
+
+}
+
+post_upgrade()
+{
+ post_install
+}