summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-05 19:36:13 -0600
committerLuis Martinez2022-02-05 19:36:46 -0600
commit897fe3bfe8beac055d9b7bc7bacadf47d963883c (patch)
treea6c1e9a3f9865e7024f20ffa54b8718b59fb412d
parentcdae948c01ea2afdf9a78e3d9876db355a2b7582 (diff)
downloadaur-897fe3bfe8beac055d9b7bc7bacadf47d963883c.tar.gz
update to 1.2.0
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG.md35
-rw-r--r--PKGBUILD15
3 files changed, 50 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ce63e8816d6..e08b0c1b6e37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fnott
pkgdesc = Keyboard driven and lightweight Wayland notification daemon
- pkgver = 1.1.2
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
url = https://codeberg.org/dnkl/fnott
changelog = CHANGELOG.md
arch = x86_64
@@ -10,11 +10,11 @@ pkgbase = fnott
makedepends = meson
makedepends = scdoc
makedepends = wayland-protocols
- makedepends = tllist>=1.0.1
+ makedepends = tllist
depends = dbus
depends = fcft
depends = wlroots
- source = fnott-1.1.2.tar.gz::https://codeberg.org/dnkl/fnott/archive/1.1.2.tar.gz
- sha512sums = dcb8776ec5fef4e06d255bfc51b41fe3bb30373f8be6540c6ece3aeff59ee8ad7ad85daad807b00de6bb528ea35198249bd0ce67b2f7e62e44206ac1d097feed
+ source = fnott-1.2.0.tar.gz::https://codeberg.org/dnkl/fnott/archive/1.2.0.tar.gz
+ sha256sums = d6cfb7efcfad5e0aa95c5fd9632c638a53a0debfc17128e70922a1ba9f841470
pkgname = fnott
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 8077752ba803..654a564d1c53 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,6 @@
# Changelog
+* [1.2.0](#1-2-0)
* [1.1.2](#1-1-2)
* [1.1.1](#1-1-1)
* [1.1.0](#1-1-0)
@@ -7,6 +8,40 @@
* [1.0.0](#1-0-0)
+## 1.2.0
+
+### Added
+
+* Configurable padding of notification text. New `fnottrc` options:
+ `padding-vertical` and `padding-horizontal`
+ (https://codeberg.org/dnkl/fnott/issues/35).
+
+
+### Changed
+
+* Default padding is now fixed at 20, instead of depending on the font
+ size. This is due to the new `padding-horizontal|vertical` options.
+
+
+### Fixed
+
+* `fnottctl actions` exiting without receiving a reply.
+* Fnott is now much better at surviving monitors being disabled and
+ re-enabled (https://codeberg.org/dnkl/fnott/issues/25).
+* Wrong font being used when the body and summary (or title and body,
+ or title and summary) is set to the same text
+ (https://codeberg.org/dnkl/fnott/issues/36).
+* Fnott no longer allocates the vertical padding space between summary
+ and body text, if the body text is empty
+ (https://codeberg.org/dnkl/fnott/issues/41).
+
+
+### Contributors
+
+* fauxmight
+* Rishabh Das
+
+
## 1.1.2
### Fixed
diff --git a/PKGBUILD b/PKGBUILD
index 780e731e3710..091217bb1ac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=fnott
-pkgver=1.1.2
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
pkgdesc="Keyboard driven and lightweight Wayland notification daemon"
arch=('x86_64')
url="https://codeberg.org/dnkl/fnott"
license=('MIT')
depends=('dbus' 'fcft' 'wlroots')
-makedepends=('git' 'meson' 'scdoc' 'wayland-protocols' 'tllist>=1.0.1')
+makedepends=('git' 'meson' 'scdoc' 'wayland-protocols' 'tllist')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('dcb8776ec5fef4e06d255bfc51b41fe3bb30373f8be6540c6ece3aeff59ee8ad7ad85daad807b00de6bb528ea35198249bd0ce67b2f7e62e44206ac1d097feed')
+sha256sums=('d6cfb7efcfad5e0aa95c5fd9632c638a53a0debfc17128e70922a1ba9f841470')
+
+prepare() {
+ cd "$pkgname"
+ sed -i "/LICENSE/c\'README.md'," meson.build
+}
build() {
arch-meson "$pkgname" build
@@ -20,5 +25,5 @@ build() {
package() {
DESTDIR="$pkgdir/" meson install -C build
- install -Dm 644 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}