summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892021-03-28 20:02:02 +0200
committerPhoton892021-03-28 20:02:02 +0200
commit89a7a88f441fe366d48e7388786c8698d1ec2858 (patch)
tree1c73f21e34981610d73629e0839d48893e256f67
parent9c4db46dc14237c7a1f24ba4b544b8b7e6237de6 (diff)
downloadaur-89a7a88f441fe366d48e7388786c8698d1ec2858.tar.gz
Update to 1.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--boost.patch11
3 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94aa080d3c66..a0cb12d40aec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jngl
pkgdesc = One of the easiest 2D game libraries for C++ and Python
- pkgver = 1.4.0
+ pkgver = 1.5.0
pkgrel = 1
url = https://bixense.com/jngl/
arch = i686
@@ -10,13 +10,13 @@ pkgbase = jngl
makedepends = ninja
depends = sdl2
depends = fontconfig
- depends = glew
+ depends = libepoxy
depends = libwebp
depends = openal
depends = libvorbis
depends = boost
- source = https://github.com/jhasse/jngl/archive/v1.4.0.tar.gz
- md5sums = cbf808e28e99a4f07617ca6b035842ba
+ source = https://github.com/jhasse/jngl/archive/v1.5.0.tar.gz
+ md5sums = 16072572c932a280bf36a3b4217f87c0
pkgname = jngl
diff --git a/PKGBUILD b/PKGBUILD
index 1dced8a379b0..3b8009f85e1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
pkgname=jngl
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=1
pkgdesc="One of the easiest 2D game libraries for C++ and Python"
arch=('i686' 'x86_64')
url="https://bixense.com/jngl/"
license=('ZLIB')
-depends=('sdl2' 'fontconfig' 'glew' 'libwebp' 'openal' 'libvorbis' 'boost')
-
+depends=('sdl2' 'fontconfig' 'libepoxy' 'libwebp' 'openal' 'libvorbis' 'boost')
makedepends=('meson' 'ninja')
source=("https://github.com/jhasse/jngl/archive/v$pkgver.tar.gz")
-md5sums=('cbf808e28e99a4f07617ca6b035842ba')
+md5sums=('16072572c932a280bf36a3b4217f87c0')
build() {
cd $srcdir/jngl-$pkgver
- mkdir build
+ mkdir -p build
cd build
meson .. --prefix=${pkgdir}/usr
}
diff --git a/boost.patch b/boost.patch
deleted file mode 100644
index 140e2dc0c3c9..000000000000
--- a/boost.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- SConstruct_old 2017-04-11 15:55:16.649483915 +0200
-+++ SConstruct 2017-04-11 15:55:58.427721847 +0200
-@@ -107,7 +107,7 @@
- env = env.Clone()
- env.ParseConfig("pkg-config --cflags --libs jngl.pc python3")
- env.Append(LIBPATH = ["src", "./python"])
-- if conf.CheckLib(["boost_python3"]):
-+ if conf.CheckLib(["boost_python3"]) or True:
- env.Append(LIBS=["boost_python3"])
- else:
- import re