summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2021-04-16 09:47:48 +1000
committerRhinoceros2021-04-16 09:47:48 +1000
commit89c45d6ba3e85ac2f96ff068003d06afd0277e3d (patch)
tree274bb9f8ce0687a8a522ab54b59d8b39acd2d918
parentdb25499706c5293ba7674dcee40980e555353601 (diff)
downloadaur-89c45d6ba3e85ac2f96ff068003d06afd0277e3d.tar.gz
Update to 0.9.15-1
* Upstream changelog: * Delete options R_ls_env_tol, R_objbr_labelerr, R_show_arg_help. * New options: R_clear_console, R_debug, R_auto_start, R_dbg_jump. * Replace options R_in_buffer, R_term and R_term_cmd with a single option: R_external_term. * Make R_rmdchunk more flexible. * Change default key binding for calling debug() from \db to \bg to avoid conflict with \d (send line). * Require either Neovim >= 0.4.3 or Vim >= 8.1.1705.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbb9e81434da..66b596110d3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = nvim-r
pkgdesc = Vim plugin to work with R
- pkgver = 0.9.14
+ pkgver = 0.9.15
pkgrel = 1
url = https://github.com/jalvesaq/nvim-r
install = nvim-r.install
arch = any
license = GPL2
- optdepends = vim>=8.0.0: either vim or neovim
- optdepends = tmux>=2.0: if using vim, necessary for sending commands to R
- optdepends = neovim>=0.2.0: either neovim or vim
+ optdepends = vim>=8.1.1705: either vim or neovim
+ optdepends = tmux>=2.0: if using vim and running R in an external terminal emulator, necessary for sending commands to R
+ optdepends = neovim>=0.4.3: either neovim or vim
optdepends = r>=3.0.0: for integration with R
optdepends = pandoc: render output from markup files
optdepends = vim-csv: inspect data.frames and matrices
conflicts = vim-r
conflicts = r-vimcom
replaces = vim-r
- source = nvim-r-0.9.14.tar.gz::https://github.com/jalvesaq/Nvim-R/archive/v0.9.14.tar.gz
- sha256sums = b4b616e8dace0c3c006467f6471c9805ed8754beb1b8aaeedad952b3eb0f25e8
+ source = nvim-r-0.9.15.tar.gz::https://github.com/jalvesaq/Nvim-R/archive/v0.9.15.tar.gz
+ sha256sums = 7f06b79d92a045f35b5bbd6fef96b3371b58b66301ddcf70a9129f75e94bfc61
pkgname = nvim-r
diff --git a/PKGBUILD b/PKGBUILD
index f4e2af3d910a..092af76274ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
pkgname=nvim-r
-pkgver=0.9.14
+pkgver=0.9.15
pkgrel=1
pkgdesc="Vim plugin to work with R"
arch=('any')
url="https://github.com/jalvesaq/${pkgname}"
license=('GPL2')
-optdepends=('vim>=8.0.0: either vim or neovim'
- 'tmux>=2.0: if using vim, necessary for sending commands to R'
- 'neovim>=0.2.0: either neovim or vim'
+optdepends=('vim>=8.1.1705: either vim or neovim'
+ 'tmux>=2.0: if using vim and running R in an external terminal emulator, necessary for sending commands to R'
+ 'neovim>=0.4.3: either neovim or vim'
'r>=3.0.0: for integration with R'
'pandoc: render output from markup files'
'vim-csv: inspect data.frames and matrices')
@@ -17,7 +17,7 @@ conflicts=('vim-r' 'r-vimcom')
replaces=('vim-r')
install='nvim-r.install'
source=("$pkgname-$pkgver.tar.gz::https://github.com/jalvesaq/Nvim-R/archive/v${pkgver}.tar.gz")
-sha256sums=('b4b616e8dace0c3c006467f6471c9805ed8754beb1b8aaeedad952b3eb0f25e8')
+sha256sums=('7f06b79d92a045f35b5bbd6fef96b3371b58b66301ddcf70a9129f75e94bfc61')
package() {
cd "Nvim-R-${pkgver}"