summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-06-13 10:35:05 -0400
committeracxz2022-06-13 10:35:05 -0400
commit89f149faf8648a118ff6b9b0eb990e969b824178 (patch)
treede0eae04a8037a2fee7bc8404e2b946a3a7e2161
parentddf3e58884cb089b5dd97ecc6183ba925999025a (diff)
downloadaur-89f149faf8648a118ff6b9b0eb990e969b824178.tar.gz
add missing deps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a0e9454f499..6ddc860b46e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = ignition-gui
pkgdesc = Builds on top of Qt to provide widgets which are useful when developing robotics applications, such as a 3D view, plots, dashboard, etc, and can be used together in a convenient unified interface.
pkgver = 6.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://gazebosim.org/libs/gui
arch = x86_64
license = Apache
makedepends = cmake
+ depends = eigen
depends = qt5-base
+ depends = qt5-quickcontrols2
depends = protobuf
depends = tinyxml2
depends = ignition-math
diff --git a/PKGBUILD b/PKGBUILD
index 56c715c6837e..3054ec54838c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ignition-gui
pkgver=6.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="Builds on top of Qt to provide widgets which are useful when developing
robotics applications, such as a 3D view, plots, dashboard, etc, and can be used
together in a convenient unified interface."
@@ -10,16 +10,18 @@ arch=('x86_64')
url="https://gazebosim.org/libs/gui"
license=('Apache')
depends=(
- qt5-base
- protobuf
- tinyxml2
- ignition-math
- ignition-common
- ignition-plugin
- ignition-transport
- ignition-rendering
- ignition-msgs
- ignition-tools
+ eigen
+ qt5-base
+ qt5-quickcontrols2
+ protobuf
+ tinyxml2
+ ignition-math
+ ignition-common
+ ignition-plugin
+ ignition-transport
+ ignition-rendering
+ ignition-msgs
+ ignition-tools
)
makedepends=('cmake')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gazebosim/gz-gui/archive/${pkgname}6_${pkgver}.tar.gz")