summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2016-05-17 15:04:38 +0300
committertrizen2016-05-17 15:04:38 +0300
commit89f903f5644a6ebfb166da1912e7383f94935c0d (patch)
tree9fe384156d82b6604ceb80a706f6b123f6c9d035
parent2514b39055836914f754cdb16b231e6930787da9 (diff)
downloadaur-89f903f5644a6ebfb166da1912e7383f94935c0d.tar.gz
- Updated to use python3. Thanks @Stebalien!
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1af8a878bff6..9ec3e6309673 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = xdot-git
pkgdesc = Interactive viewer for Graphviz dot files (git version)
- pkgver = 2fb8a8a
+ pkgver = 0.7.r10.g322b889
pkgrel = 1
url = https://github.com/jrfonseca/xdot.py
arch = any
- license = LGPL
+ license = LGPL2.1
makedepends = git
depends = graphviz
- depends = pygtk
- depends = python2-distribute
- depends = python2-gobject
+ depends = python
+ depends = gtk3
+ depends = python-gobject
+ depends = python-cairo
+ depends = python-setuptools
provides = xdot
conflicts = xdot
source = git://github.com/jrfonseca/xdot.py.git
diff --git a/PKGBUILD b/PKGBUILD
index 268d4fca27c4..e38cfd75f79f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname='xdot.py'
pkgname=xdot-git
-pkgver=2fb8a8a
+pkgver=0.7.r10.g322b889
pkgrel=1
pkgdesc="Interactive viewer for Graphviz dot files (git version)"
arch=('any')
url="https://github.com/jrfonseca/xdot.py"
-license=('LGPL')
+license=('LGPL2.1')
makedepends=('git')
-depends=('graphviz' 'pygtk' 'python2-distribute' 'python2-gobject')
+depends=('graphviz' 'python' 'gtk3' 'python-gobject' 'python-cairo' 'python-setuptools')
provides=('xdot')
conflicts=('xdot')
@@ -19,10 +19,10 @@ md5sums=('SKIP')
pkgver() {
cd $_pkgname
- git describe --always | sed -e 's|-|.|g'
+ git describe --tags | sed -e 's|-|.r|' | sed -e 's|-|.|'
}
package() {
cd $_pkgname
- python2 setup.py install --root=$pkgdir --optimize=1
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
}