summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422019-10-09 16:11:16 +0200
committerSkycoder422019-10-09 16:11:16 +0200
commit8a1c9ba9ebf0ecfd70b3e662bbf0d0c38ad27240 (patch)
treeff8836185bc6e8fe61d32ff592d8305e36baebae
downloadaur-8a1c9ba9ebf0ecfd70b3e662bbf0d0c38ad27240.tar.gz
Created AUR repository at version 3.0.0
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD86
-rw-r--r--qt5-autoupdater.rule1
-rw-r--r--subpkg.rule1
4 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e59242ad884
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = qt5-autoupdater
+ pkgdesc = A Qt library to automatically check for updates and install them
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/Skycoder42/QtAutoUpdater
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = packagekit-qt5
+ makedepends = qdep
+ makedepends = python
+ makedepends = doxygen
+ makedepends = graphviz
+ depends = qt5-base
+ depends = qt5-quickcontrols2
+ optdepends = repkg: Automatically rebuild the package on dependency updates
+ source = qt5-autoupdater-3.0.0::git+https://github.com/Skycoder42/QtAutoUpdater.git#tag=3.0.0
+ source = qt5-autoupdater.rule
+ source = subpkg.rule
+ sha256sums = SKIP
+ sha256sums = 53d4064bdd7387926f655be81326b0b56b5a1b4abd895a870466d02456594cbf
+ sha256sums = c1650aebcb7175bf4b163573205801df4637180aaf3583703338546bb66dbca6
+
+pkgname = qt5-autoupdater
+
+pkgname = qt5-autoupdater-qtifw
+ depends = qt5-autoupdater
+ optdepends =
+
+pkgname = qt5-autoupdater-packagekit
+ depends = qt5-autoupdater
+ depends = packagekit-qt5
+ optdepends =
+
+pkgname = qt5-autoupdater-doc
+ depends = qt5-autoupdater
+ optdepends =
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07d04f561409
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgbase=qt5-autoupdater
+pkgname=(qt5-autoupdater qt5-autoupdater-qtifw qt5-autoupdater-packagekit qt5-autoupdater-doc)
+group=qt5-autoupdater-full
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="A Qt library to automatically check for updates and install them"
+arch=('i686' 'x86_64')
+url="https://github.com/Skycoder42/QtAutoUpdater"
+license=('BSD')
+depends=('qt5-base' 'qt5-quickcontrols2')
+makedepends=('git' 'qt5-tools' 'packagekit-qt5' 'qdep' 'python' 'doxygen' 'graphviz')
+optdepends=("repkg: Automatically rebuild the package on dependency updates")
+_pkgfqn=$pkgname-$pkgver
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtAutoUpdater.git#tag=$pkgver"
+ "$pkgname.rule"
+ "subpkg.rule")
+sha256sums=('SKIP'
+ '53d4064bdd7387926f655be81326b0b56b5a1b4abd895a870466d02456594cbf'
+ 'c1650aebcb7175bf4b163573205801df4637180aaf3583703338546bb66dbca6')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake "../$_pkgfqn/"
+ make
+ make doxygen
+}
+
+package_qt5-autoupdater() {
+ cd build/src/autoupdatercore
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../autoupdaterwidgets
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../imports
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../translations
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../..
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/system/${pkgname}.rule"
+}
+
+package_qt5-autoupdater-qtifw() {
+ depends=('qt5-autoupdater')
+ optdepends=()
+
+ cd build/src/plugins/updater/qtifw
+ make INSTALL_ROOT="$pkgdir" install
+
+ cd "../../../../../$_pkgfqn"
+ install -D -m644 "../subpkg.rule" "$pkgdir/etc/repkg/rules/system/${pkgname}.rule"
+}
+
+package_qt5-autoupdater-packagekit() {
+ depends=('qt5-autoupdater' 'packagekit-qt5')
+ optdepends=()
+
+ cd build/src/plugins/updater/qpackagekit
+ make INSTALL_ROOT="$pkgdir" install
+
+ cd "../../../../../$_pkgfqn"
+ install -D -m644 "../subpkg.rule" "$pkgdir/etc/repkg/rules/system/${pkgname}.rule"
+
+}
+
+package_qt5-autoupdater-doc() {
+ depends=('qt5-autoupdater')
+ optdepends=()
+
+ cd build/doc
+ make INSTALL_ROOT="$pkgdir" install
+
+ # DROP file paths from doc tags
+ find "$pkgdir/usr/share/doc/qt" -type f -name '*.tags' \
+ -exec sed -i -e 's:<path>[^<]*<\/path>:<path>/usr/include/qt/QtAutoUpdater</path>:g' {} \;
+}
diff --git a/qt5-autoupdater.rule b/qt5-autoupdater.rule
new file mode 100644
index 000000000000..4270869a4437
--- /dev/null
+++ b/qt5-autoupdater.rule
@@ -0,0 +1 @@
+qt5-base=v qt5-quickcontrols2=v packagekit-qt5=v
diff --git a/subpkg.rule b/subpkg.rule
new file mode 100644
index 000000000000..c2e2f5aa8366
--- /dev/null
+++ b/subpkg.rule
@@ -0,0 +1 @@
+qt5-autoupdater