summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2023-12-10 13:27:46 -0600
committerAlfredo Ramos2023-12-10 13:27:46 -0600
commit8a1ce267117c5aaad97ceaa5daa111ba46cccccf (patch)
tree5a5322c9779594b92bf6949fbcf06db529e2fd49
parent12e91004712e3d9977c92002567030f24ca341e2 (diff)
downloadaur-8a1ce267117c5aaad97ceaa5daa111ba46cccccf.tar.gz
Update to version 1.6.1
-rw-r--r--.SRCINFO11
-rw-r--r--.gitattributes3
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD54
-rwxr-xr-xversion_check.sh4
-rw-r--r--zoho-mail-desktop.desktop11
6 files changed, 35 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daba7d9268d2..be56f24b153c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = zoho-mail-desktop
- pkgdesc = The desktop version of your favorite mailsuite!
- pkgver = 1.5.3
+ pkgdesc = Lite desktop version of Zoho email client.
+ pkgver = 1.6.1
pkgrel = 1
url = https://www.zoho.com/mail/desktop
arch = x86_64
license = custom
- source = https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v1.5.3.AppImage
- source = zoho-mail-desktop.desktop
- sha256sums = 8618e8ba59dc1dfd287b09d923c260f57a85cc8000ae5999ebc14dc21485c15b
- sha256sums = SKIP
+ depends = hicolor-icon-theme
+ source = https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-lite-installer-x64-v1.6.1.deb
+ sha512sums = f17b61c5326531f6b4537d90327a6d2bf5f782fe3590a4fc809fca4c44357d1ccea591b320d11c0ad5dd41672c16a7e49b7c2d4ab1d03ef3f962be7f0cb9fe27
pkgname = zoho-mail-desktop
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..37a4a692325f
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,3 @@
+* text=auto
+.gitignore export-ignore
+.gitattributes export-ignore
diff --git a/.gitignore b/.gitignore
index 204d355cd99b..5618e5b5286b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
-pkg/
-src/
-*.deb
-*.pkg.tar*
-*.zst
-*.AppImage \ No newline at end of file
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!.gitattributes
diff --git a/PKGBUILD b/PKGBUILD
index 0e00c598028c..496df792cdf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,34 @@
-# Maintainer: Sabu Siyad <hello@ssiyad.com>
-# This PKGBUILD is maintained at https://github.com/ssiyad/pkgbuilds/
-
-# Past Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.me>
-# Past Maintainer: Emerson Almeida <duke.m16@gmail.com>
-# Past Contributor: Emerson Almeida <duke.m16@gmail.com>
+# Maintainer: Alfredo Ramos <alfredo.ramos@tutanota.com>
+# Contributor: Jose Galvez (galvez_65)
+# Contributor: Sabu Siyad <hello@ssiyad.com>
+# Contributor: Hunter Wittenborn <hunter@hunterwittenborn.me>
+# Contributor: Emerson Almeida <duke.m16@gmail.com>
pkgname=zoho-mail-desktop
-pkgver=1.5.3
+pkgver=1.6.1
pkgrel=1
-pkgdesc="The desktop version of your favorite mailsuite!"
+pkgdesc='Lite desktop version of Zoho email client.'
arch=('x86_64')
+url='https://www.zoho.com/mail/desktop'
license=('custom')
-url="https://www.zoho.com/mail/desktop"
-source=("https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v${pkgver}.AppImage"
- "zoho-mail-desktop.desktop")
-sha256sums=("8618e8ba59dc1dfd287b09d923c260f57a85cc8000ae5999ebc14dc21485c15b"
- "SKIP")
+depends=('hicolor-icon-theme')
-prepare() {
- chmod +x "zoho-mail-desktop-x64-v${pkgver}.AppImage"
- ./"zoho-mail-desktop-x64-v${pkgver}.AppImage" --appimage-extract
-}
+source=(
+ "https://downloads.zohocdn.com/zmail-desktop/linux/${pkgname}-lite-installer-x64-v${pkgver}.deb"
+)
+sha512sums=(
+ 'f17b61c5326531f6b4537d90327a6d2bf5f782fe3590a4fc809fca4c44357d1ccea591b320d11c0ad5dd41672c16a7e49b7c2d4ab1d03ef3f962be7f0cb9fe27'
+)
package() {
- mkdir -p "${pkgdir}/opt"
- cp -Lr "${srcdir}/squashfs-root" "${pkgdir}/opt"
- mv "${pkgdir}/opt/squashfs-root" "${pkgdir}/opt/zoho-mail-desktop"
- find "${pkgdir}/opt" -type d -exec chmod +rx {} \;
-
- mkdir -p "${pkgdir}/usr/bin"
- echo '#!/usr/bin/env bash
- gtk-launch zoho-mail-desktop.desktop' | tee "${pkgdir}/usr/bin/zoho-mail-desktop"
- chmod +x "${pkgdir}/usr/bin/zoho-mail-desktop"
+ # Install application, icons, docs and desktop file
+ tar -C "${pkgdir}" -xavf "${srcdir}/data.tar.xz"
- mkdir -p "${pkgdir}/usr/share/applications"
- cp -Lr "${srcdir}/zoho-mail-desktop.desktop" "${pkgdir}/usr/share/applications"
+ # Create symbolic link
+ install -dm 755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/Zoho Mail - Desktop/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- for img in 1024x1024 128x128 16x16 256x256 32x32 48x48 512x512 64x64; do
- mkdir -p "${pkgdir}/usr/share/icons/hicolor/${img}/apps"
- cp -Lr "${srcdir}/squashfs-root/usr/share/icons/hicolor/${img}/apps/zoho-mail-desktop.png" "${pkgdir}/usr/share/icons/hicolor/${img}/apps/"
- done
+ # Install license
+ install -Dm 644 "${pkgdir}/opt/Zoho Mail - Desktop/resources/EULA.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.pdf"
}
diff --git a/version_check.sh b/version_check.sh
deleted file mode 100755
index c4f994481fc6..000000000000
--- a/version_check.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-curl -s 'https://downloads.zohocdn.com/zmail-desktop/artifacts.json' | \
-jq -r .linux.primary.x64 | \
-sed 's|https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v||g' | \
-sed 's|.AppImage||g'
diff --git a/zoho-mail-desktop.desktop b/zoho-mail-desktop.desktop
deleted file mode 100644
index ddb4a3e0bdc5..000000000000
--- a/zoho-mail-desktop.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=Zoho Mail - Desktop
-Exec=/opt/zoho-mail-desktop/AppRun %U
-Terminal=false
-Type=Application
-Icon=zoho-mail-desktop
-StartupWMClass=Zoho Mail - Desktop
-X-AppImage-Version=1.2.0
-Comment=The desktop version of your favorite mailsuite!
-MimeType=x-scheme-handler/mailto;
-Categories=Office;