summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarugalev2017-01-13 19:04:35 +0500
committerarugalev2017-01-13 19:04:35 +0500
commit8a28adb8d268f9b5d25e7fb66e477883a9d9281b (patch)
treef8d31f5000428515b994d50deb877298eee2fe53
downloadaur-8a28adb8d268f9b5d25e7fb66e477883a9d9281b.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD18
-rwxr-xr-ximagy-xfce418
-rw-r--r--imagy-xfce4-0.1-1-x86_64.pkg.tar.xzbin0 -> 13124 bytes
6 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59b3b00108ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = imagy-xfce4
+ pkgdesc = Imagy.me screenshooter for xfce4
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://imagy.me
+ arch = x86
+ arch = x86_64
+ license = MIT
+ depends = xfce4-screenshooter
+ source = imagy-xfce4
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = imagy-xfce4
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8fec16c6548b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+imagy-xfce-*
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5ec5dbfa1286
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Anatoly Rugalev
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a65b8fa78037
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Anatoly Rugalev <anatoly.rugalev g-mail>
+
+pkgname=imagy-xfce4
+pkgver=0.1
+pkgrel=1
+url="http://imagy.me"
+pkgdesc="Imagy.me screenshooter for xfce4"
+arch=('x86' 'x86_64')
+depends=('xfce4-screenshooter')
+source=('imagy-xfce4' 'LICENSE')
+md5sums=('SKIP' 'SKIP')
+license=('MIT')
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/licenses/imagy-xfce4
+ install -m755 imagy-xfce4 "$pkgdir"/usr/bin/imagy-xfce4
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/imagy-xfce4/LICENSE
+}
diff --git a/imagy-xfce4 b/imagy-xfce4
new file mode 100755
index 000000000000..75eddc87de64
--- /dev/null
+++ b/imagy-xfce4
@@ -0,0 +1,18 @@
+#!/bin/bash
+# by Anatoly Rugalev
+
+UPLOAD_URI="http://imagy.me/upload"
+
+TMP_FILE=`xfce4-screenshooter -ro echo`
+
+if [ -n "$TMP_FILE" ]; then
+ URL=$(curl -s --form imagedata=@$TMP_FILE $UPLOAD_URI | awk '{print $1}')
+
+ echo "$URL" | xclip -selection primary
+ echo "$URL" | xclip -selection clipboard
+
+ notify-send "Screenshot URL was copied to clipboard"
+ echo $URL
+
+ rm $TMP_FILE
+fi
diff --git a/imagy-xfce4-0.1-1-x86_64.pkg.tar.xz b/imagy-xfce4-0.1-1-x86_64.pkg.tar.xz
new file mode 100644
index 000000000000..04420cf678af
--- /dev/null
+++ b/imagy-xfce4-0.1-1-x86_64.pkg.tar.xz
Binary files differ