summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122022-08-18 21:52:37 +0200
committerwillemw122022-08-18 21:52:37 +0200
commit8a363d683dd77b804c18355d8ce8559ade9fb04d (patch)
tree0461db1852936df932f52815b35ee199d63f056c
parent231dfb9476ccf5a067fce9550fb4c30fde2d8028 (diff)
downloadaur-8a363d683dd77b804c18355d8ce8559ade9fb04d.tar.gz
Don't install the LICENSE file.
Minor edits.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5d50880df2d..36c8458038e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = adb-sync-git
- pkgdesc = A tool to synchronize files between a PC and an Android device using the ADB
- pkgver = r23.b8813dc
+ pkgdesc = Synchronize files between a PC and an Android device using the ADB (Android Debug Bridge)
+ pkgver = r35.fb7c549
pkgrel = 1
url = https://github.com/google/adb-sync
arch = any
license = Apache
makedepends = git
- depends = python
depends = android-tools
depends = android-udev
- source = git+https://github.com/google/adb-sync
- sha1sums = SKIP
+ depends = python
+ source = adb-sync-git::git+https://github.com/google/adb-sync.git
+ sha256sums = SKIP
pkgname = adb-sync-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ce6f5de20bb3..10cfec1db580 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-# Maintainer: Anatol Pomozov <anatol dot pomozov at gmail>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Anatol Pomozov <anatol dot pomozov at gmail>
pkgname=adb-sync-git
-pkgver=r23.b8813dc
+pkgver=r35.fb7c549
pkgrel=1
-pkgdesc='A tool to synchronize files between a PC and an Android device using the ADB'
+pkgdesc='Synchronize files between a PC and an Android device using the ADB (Android Debug Bridge)'
+arch=('any')
url='https://github.com/google/adb-sync'
-arch=(any)
-depends=(python android-tools android-udev)
-makedepends=(git)
-license=(Apache)
-source=(git+https://github.com/google/adb-sync)
-sha1sums=('SKIP')
+license=('Apache')
+depends=('android-tools' 'android-udev' 'python')
+makedepends=('git')
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
pkgver() {
- cd adb-sync
+ cd $pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd adb-sync
- install -m755 -d "$pkgdir/usr/bin"
- install -m755 -t "$pkgdir/usr/bin" adb-sync adb-channel
-
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 $pkgname/{adb-sync,adb-channel} -t "$pkgdir/usr/bin"
}
+