summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2018-12-23 10:01:03 +0100
committerSibren Vasse2018-12-23 10:21:13 +0100
commit8a3b02f7ad7379d2856b02deda0f2e26d8d0690b (patch)
tree86dfe2c081c03566df289dcd3d661316b1835c3e
downloadaur-8a3b02f7ad7379d2856b02deda0f2e26d8d0690b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD26
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc334ffdb740
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-casttube
+ pkgdesc = YouTube chromecast api
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://github.com/ur1katz/casttube
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-requests
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/c/casttube/casttube-0.2.0.tar.gz
+ source = LICENSE
+ sha256sums = f25b3c634efe702896233690f7590e8d6311590910f18dbb763b90419d9ef53c
+ sha256sums = 7178b432584adb0a05ef3b47c2f458a8c4ff378fd364b9e2498971d77c7ffa3e
+
+pkgname = python-casttube
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e05eb86c1ee3
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Uri Katz
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e72e150ffd1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
+
+_name='casttube'
+pkgname="python-$_name"
+pkgver='0.2.0'
+pkgrel=1
+pkgdesc="YouTube chromecast api"
+url="http://github.com/ur1katz/casttube"
+depends=('python' 'python-requests' 'python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/c/${_name}/${_name}-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('f25b3c634efe702896233690f7590e8d6311590910f18dbb763b90419d9ef53c'
+ '7178b432584adb0a05ef3b47c2f458a8c4ff378fd364b9e2498971d77c7ffa3e')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}