summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-08-29 20:51:50 +0800
committeryjun2021-08-29 20:51:50 +0800
commit8a5c8f5abbb5d4bdae52712f21df929d11cc9dff (patch)
tree684a4f8a210b6f7892fafb23225945b855015894
parentfefad7fd0d6eb49718585eca89d6825f1be33932 (diff)
downloadaur-8a5c8f5abbb5d4bdae52712f21df929d11cc9dff.tar.gz
pkgbuild: use offical download link instead of local URL
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 20 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21f77c5f903d..7e36622c6670 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = stm32cubemonitor
- pkgdesc = graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time
+ pkgdesc = Graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.st.com/en/development-tools/stm32cubemonitor.html
arch = x86_64
- license = custom
+ license = SLA0048
depends = gtk3
depends = nss
depends = libxss
@@ -13,12 +13,9 @@ pkgbase = stm32cubemonitor
depends = xdg-utils
depends = at-spi2-core
depends = util-linux-libs
- optdepends = stlink: stlink udev files provide
- provides = stm32cubemonitor-bin
- conflicts = stm32cubemonitor-bin
+ depends = stlink
options = !strip
- source = local://en.STM32CubeMonitor_lin_v1-2-0.zip
+ source = en.STM32CubeMonitor_lin_v1-2-0.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/70/4c/e0/01/b2/df/4c/45/STM32CubeMonitor_lin_v1-2-0/files/STM32CubeMonitor_lin_v1-2-0.zip/jcr:content/translations/en.STM32CubeMonitor_lin_v1-2-0.zip
sha256sums = 89ca4051cea2e0dd115f9e5e1cb1344560fd408471d7a5caae1ca15cb736aa35
pkgname = stm32cubemonitor
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5064501626d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.zst
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 1311d8f970f1..646c0e117ac7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,21 @@
# Maintainer: yjun <jerrysteve1101@gmail.com>
pkgname=stm32cubemonitor
+_pkgname=STM32CubeMonitor
pkgver=1.2.0
-pkgrel=1
-pkgdesc="graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time"
+pkgrel=2
+pkgdesc="Graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time"
arch=('x86_64')
url="https://www.st.com/en/development-tools/stm32cubemonitor.html"
-license=('custom')
-depends=('gtk3' 'nss' 'libxss' 'libnotify' 'libxtst' 'xdg-utils' 'at-spi2-core' 'util-linux-libs')
-optdepends=('stlink: stlink udev files provide')
-provides=("${pkgname}-bin")
-conflicts=("${pkgname}-bin")
+license=('SLA0048')
+# package stlink provides stlink udev files
+depends=('gtk3' 'nss' 'libxss' 'libnotify' 'libxtst' 'xdg-utils' 'at-spi2-core' 'util-linux-libs' 'stlink')
options=('!strip')
-_pkg_file_name=en.STM32CubeMonitor_lin_v${pkgver//./-}.zip
-source=("local://${_pkg_file_name}")
+_pkg_file_name=${_pkgname}_lin_v${pkgver//./-}
+# https://www.st.com/content/st_com_cx/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor/_jcr_content/get-software/get-software-table-body.nocache.html/st-site-cx/components/containers/product/get-software-table-body.html
+source=("en.${_pkg_file_name}.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/70/4c/e0/01/b2/df/4c/45/${_pkg_file_name}/files/${_pkg_file_name}.zip/jcr:content/translations/en.${_pkg_file_name}.zip")
sha256sums=('89ca4051cea2e0dd115f9e5e1cb1344560fd408471d7a5caae1ca15cb736aa35')
-_DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
-if [ ! -f ${PWD}/${_pkg_file_name} ]; then
- if [ -f $_DOWNLOADS_DIR/${_pkg_file_name} ]; then
- ln -sfn $_DOWNLOADS_DIR/${_pkg_file_name} ${PWD}
- else
- echo ""
- echo "The package can be downloaded here: "
- echo "Please remember to put a downloaded package ${_pkg_file_name} into the build directory ${PWD} or $_DOWNLOADS_DIR"
- echo ""
- fi
-fi
-
# Extracted Files from ${_pkg_file_name}
# ├── driver
# │ └── st-stlink-udev-rules-1.0.2-3-linux-all.deb
@@ -56,9 +44,9 @@ package() {
ln -fs /opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
# license
- for license in ${srcdir}/licenses/*
+ for _license in ${srcdir}/licenses/*
do
- install -Dm644 "${license}" -t ${pkgdir}/usr/share/licenses/${pkgname}/
+ install -Dm644 "${_license}" -t ${pkgdir}/usr/share/licenses/${pkgname}/
done
}