summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2015-07-24 21:24:45 -0700
committerAntony Lee2015-07-24 21:24:45 -0700
commit8a88980f51d6550066c66f37bd4a1e8e2a21a5f7 (patch)
tree2c7d8f14597ed073b76d9f1672938c1138ec3c27
downloadaur-8a88980f51d6550066c66f37bd4a1e8e2a21a5f7.tar.gz
Initial commit.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc9c258156d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-logging_tree
+ pkgdesc = Introspect and display the logger tree inside "logging"
+ pkgver = 1.6
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/logging_tree/
+ arch = any
+ license = BSD
+ depends = python
+ source = http://pypi.python.org/packages/source/l/logging_tree/logging_tree-1.6.tar.gz
+ md5sums = 33ef7eaa1533a50cf67ed1c49a48cfdd
+
+pkgname = python-logging_tree
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..928f68e675a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+pkgname=python-logging_tree
+pkgver=1.6
+pkgrel=1
+pkgdesc='Introspect and display the logger tree inside "logging"'
+arch=('any')
+url='http://pypi.python.org/pypi/logging_tree/'
+license=('BSD')
+depends=('python')
+source=("http://pypi.python.org/packages/source/l/logging_tree/logging_tree-$pkgver.tar.gz")
+md5sums=('33ef7eaa1533a50cf67ed1c49a48cfdd')
+
+build() {
+ cd "$srcdir/logging_tree-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/logging_tree-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+