summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-04-21 19:16:06 +0800
committerq234rty2023-04-21 19:16:06 +0800
commit8aba9446224df2370dd4a835edb694e636675d2f (patch)
tree16484c7a51d52eb4e4faaff7eb8d18029864e7b5
parent71255c160d096a10a1bc80cc77c88ca36d167c89 (diff)
downloadaur-8aba9446224df2370dd4a835edb694e636675d2f.tar.gz
Initial takeover
-rw-r--r--.SRCINFO29
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD64
3 files changed, 57 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d35470de8cd3..4e5b6e2442ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = curl-http3
pkgdesc = An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3
- pkgver = 7.82.0
+ pkgver = 8.0.1
pkgrel = 1
url = https://curl.haxx.se
arch = x86_64
@@ -10,16 +10,29 @@ pkgbase = curl-http3
makedepends = go
makedepends = cmake
depends = ca-certificates
- depends = openssl
- depends = zlib
- depends = libpsl
- depends = libnghttp2
+ depends = brotli
+ depends = libbrotlidec.so
+ depends = libgssapi_krb5.so
+ depends = krb5
depends = libidn2
depends = libidn2.so
- source = https://curl.haxx.se/download/curl-7.82.0.tar.gz
- source = https://curl.haxx.se/download/curl-7.82.0.tar.gz.asc
+ depends = libnghttp2
+ depends = libpsl
+ depends = libpsl.so
+ depends = libssh2
+ depends = libssh2.so
+ depends = openssl
+ depends = zlib
+ depends = zstd
+ depends = libzstd.so
+ source = https://curl.haxx.se/download/curl-8.0.1.tar.gz
+ source = https://curl.haxx.se/download/curl-8.0.1.tar.gz.asc
+ source = git+https://github.com/cloudflare/quiche.git#tag=0.17.1
+ source = git+https://github.com/google/boringssl.git
validpgpkeys = 27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2
- sha512sums = e3084f0fa083f7f93eac923edbfdddb5fd0a372b94673ba9d4427a2b95508898c15ecdf63b99a1c1f6cf3215e27b06cbaa2b7073df038d43b362e586f92495d3
+ sha512sums = 87d945e65176613c6296f8b130bd6c5355e3ca3c62ee4010edd481950cad9760482fd3be8a84e51501c118c29ebc284b8f87c49b06f9d248e9da5819fda38f8f
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = curl-http3
diff --git a/Makefile b/Makefile
index 376662402b15..7b07cba71736 100644
--- a/Makefile
+++ b/Makefile
@@ -2,5 +2,5 @@
all:
@rm -f *.tar.* .SRCINFO
- @sed -i 's/^sha512sums=.*$$/$(shell makepkg -g)/g' PKGBUILD
+ @updpkgsums
@makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 6de72a79727d..ce7cf63bba2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
# Maintainer: Hendrik 'T4cC0re' Meyer <aur@t4cc0.re>
pkgname=curl-http3
-pkgver=7.82.0
+pkgver=8.0.1
pkgrel=1
pkgdesc="An URL retrieval utility and library - compiled with HTTP/3 support - binary is called curl3"
arch=('x86_64')
url="https://curl.haxx.se"
license=('MIT')
-depends=('ca-certificates' 'openssl' 'zlib' 'libpsl' 'libnghttp2'
- 'libidn2' 'libidn2.so')
+depends=('ca-certificates' 'brotli' 'libbrotlidec.so' 'libgssapi_krb5.so'
+ 'krb5' 'libidn2' 'libidn2.so' 'libnghttp2' 'libpsl' 'libpsl.so'
+ 'libssh2' 'libssh2.so' 'openssl' 'zlib' 'zstd' 'libzstd.so')
makedepends=('rust' 'git' 'go' 'cmake')
-source=("https://curl.haxx.se/download/curl-$pkgver.tar.gz"{,.asc})
+_quiche_ref=0.17.1
+source=("https://curl.haxx.se/download/curl-$pkgver.tar.gz"{,.asc}
+ "git+https://github.com/cloudflare/quiche.git#tag=${_quiche_ref}"
+ "git+https://github.com/google/boringssl.git")
validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg
-#source=("curl-$pkgver.zip::https://github.com/curl/curl/archive/master.zip")
-_quiche_ref=0.12.0
-
-build(){
- rm -rf quiche
- ## Build quiche
- mkdir quiche
+prepare() {
cd quiche
- git init
- git remote add origin https://github.com/cloudflare/quiche.git
- git fetch --depth 1 origin ${_quiche_ref}
- git checkout FETCH_HEAD
- git submodule update --init --recursive
-
- cargo build --release --features ffi,pkg-config-meta,qlog
+ git submodule init
+ git config submodule.boringssl.url "${srcdir}"/boringssl
+ git -c protocol.file.allow=always submodule update quiche/deps/boringssl
+}
+build() {
+ #Build quiche
+ cd quiche
+ CFLAGS+=' -ffat-lto-objects'
+ cargo build --package quiche --release --features ffi,pkg-config-meta,qlog
mkdir quiche/deps/boringssl/src/lib
ln -vnf $(find target/release -name libcrypto.a -o -name libssl.a) quiche/deps/boringssl/src/lib/
cd ..
@@ -34,11 +34,11 @@ build(){
## Build curl
cd "curl-${pkgver}"
- ./buildconf
+ autoreconf -fi
## Arch Linux build flags + BoringSSL and quiche
./configure \
- LDFLAGS="-Wl,-rpath,${PWD}/../quiche/target/release" \
- --with-ssl=$PWD/../quiche/quiche/deps/boringssl/src \
+ LDFLAGS="-Wl,-L,${PWD}/../quiche/target/release" \
+ --with-openssl=$PWD/../quiche/quiche/deps/boringssl/src \
--with-quiche=$PWD/../quiche/target/release \
--enable-alt-svc \
--prefix=/usr \
@@ -49,6 +49,8 @@ build(){
--disable-shared \
--enable-ipv6 \
--enable-threaded-resolver \
+ --with-gssapi \
+ --with-libssh2 \
--with-random=/dev/urandom \
--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
make
@@ -56,24 +58,28 @@ build(){
package() {
cd "curl-${pkgver}"
-# cd "curl-master"
make DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" install -C scripts
+ LD_LIBRARY_PATH=$PWD/../quiche/target/release make DESTDIR="$pkgdir" install -C scripts
- # license
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
cd ..
-
+
# rename curl to avoid conflicts
mv "${pkgdir}/usr/bin/curl" "${pkgdir}/usr/bin/curl3"
mv "${pkgdir}/usr/bin/curl-config" "${pkgdir}/usr/bin/curl-config3"
# Remove stuff that would conflict with core/curl
rm -rf "${pkgdir}/usr/lib" "${pkgdir}/usr/share" "${pkgdir}/usr/include"
-
- # libquice is requried
+
+ # libquice is required
install -Dm755 quiche/target/release/libquiche.so "${pkgdir}/usr/lib/libquiche.so"
+
+ # license
+ install -Dm644 "curl-${pkgver}"/COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 quiche/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING-quiche"
+ install -Dm644 quiche/quiche/deps/boringssl/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-boringssl"
}
-sha512sums=('d4c4a785876e0d1ba1c1adbe65528d56a8b81fc03ff724e87819cfe51aca60f8a7bf2ac9384f30c3a6bbd28669b2bd3e9a6794737243c836c4902d085a72c474'
+sha512sums=('87d945e65176613c6296f8b130bd6c5355e3ca3c62ee4010edd481950cad9760482fd3be8a84e51501c118c29ebc284b8f87c49b06f9d248e9da5819fda38f8f'
+ 'SKIP'
+ 'SKIP'
'SKIP')