summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-02-25 16:48:51 -0300
committerDaniel Bermond2023-02-25 16:48:51 -0300
commit8af426c6ce8fd0bc74b7e90b03eb94de0e31456e (patch)
treeaa54128c9882fc6adeea7d13110e6809482393cc
parent421a3871b23e860fbfc75d1e37eb132cb876d2bc (diff)
downloadaur-8af426c6ce8fd0bc74b7e90b03eb94de0e31456e.tar.gz
Update SPIRV tools and headers branches. Update cmake commands.
Update SPIRV tools and headers branches to fix build. Otherwise, makepkg is unable to checkout.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 744771aeedc9..b9ec96074af9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = intel-graphics-compiler-git
pkgdesc = Intel Graphics Compiler for OpenCL (git version)
- pkgver = 1.0.11485.r643.g58a8c46f1
+ pkgver = 1.0.13404.r94.g98cd86ea4
pkgrel = 1
epoch = 1
url = https://github.com/intel/intel-graphics-compiler/
@@ -23,8 +23,8 @@ pkgbase = intel-graphics-compiler-git
source = git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_110
source = git+https://github.com/intel/opencl-clang.git#branch=ocl-open-110
source = git+https://github.com/llvm/llvm-project.git#tag=llvmorg-11.1.0
- source = git+https://github.com/KhronosGroup/SPIRV-Tools.git
- source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#branch=main
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#branch=main
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index efbcef467d4f..49b90daca490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=intel-graphics-compiler-git
-pkgver=1.0.11485.r643.g58a8c46f1
+pkgver=1.0.13404.r94.g98cd86ea4
_llvmver=11
pkgrel=1
epoch=1
@@ -19,8 +19,8 @@ source=('git+https://github.com/intel/intel-graphics-compiler.git'
"git+https://github.com/KhronosGroup/SPIRV-LLVM-Translator.git#branch=llvm_release_${_llvmver}0"
"git+https://github.com/intel/opencl-clang.git#branch=ocl-open-${_llvmver}0"
"git+https://github.com/llvm/llvm-project.git#tag=llvmorg-${_llvmver}.1.0"
- 'git+https://github.com/KhronosGroup/SPIRV-Tools.git'
- 'git+https://github.com/KhronosGroup/SPIRV-Headers.git')
+ 'git+https://github.com/KhronosGroup/SPIRV-Tools.git#branch=main'
+ 'git+https://github.com/KhronosGroup/SPIRV-Headers.git#branch=main')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -44,6 +44,7 @@ build() {
export CXXFLAGS+=' -Wno-error=restrict -Wno-error=deprecated-declarations'
EMAIL='someone@archlinux.org' \
cmake -B build -S intel-graphics-compiler \
+ -G 'Unix Makefiles' \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='lib' \
@@ -58,11 +59,11 @@ build() {
-DCCLANG_FROM_SYSTEM='OFF' \
-DINSTALL_GENX_IR='ON' \
-Wno-dev
- make -C build
+ cmake --build build
}
package() {
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
install -D -m644 igc/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
mv "${pkgdir}/usr/include"/opencl-c{,-base}.h "${pkgdir}/usr/include/igc"
mv "${pkgdir}/usr/lib/igc/NOTICES.txt" "${pkgdir}/usr/share/licenses/${pkgname}"