summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-22 10:52:55 +0800
committerzxp198210052023-11-22 10:52:55 +0800
commit8b062635bf270357ce3c613d4c98d3d89d1e943c (patch)
tree1184f1742652f3391e309d558c7785b468d5f724
parent947af36ace087aabe7b26b51a0bca503d381d00a (diff)
downloadaur-8b062635bf270357ce3c613d4c98d3d89d1e943c.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
-rw-r--r--whalebird.sh5
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b559b215784..e0ad918d4c6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = whalebird-bin
pkgdesc = An Electron based Mastodon, Pleroma, and Misskey client
pkgver = 5.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://whalebird.social/
arch = x86_64
license = GPL3
- depends = bash
depends = electron22
provides = whalebird=5.1.1
conflicts = whalebird
source = whalebird-5.1.1.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v5.1.1/Whalebird-5.1.1-linux-amd64.deb
source = whalebird.sh
sha256sums = 556acfb66a0f37d7be1b838c37aa371228efd3655c6d212ac2ecd5749c9ec57a
- sha256sums = d7992b859b00b218f3102b56cd1f038b89ef33a6fd3ac9b409e491c4c442ec06
+ sha256sums = 7923440bf061d75d34e967f7f5ac538c0686ab0c23b2f522c8c6276ec823b36b
pkgname = whalebird-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3674e70f92e7..9d27d4d6b465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,32 @@
pkgname=whalebird-bin
_pkgname=Whalebird
pkgver=5.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="An Electron based Mastodon, Pleroma, and Misskey client"
arch=('x86_64')
url="https://whalebird.social/"
-_githuburl="https://github.com/h3poteto/whalebird-desktop"
+_ghurl="https://github.com/h3poteto/whalebird-desktop"
license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron22')
-source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
- "${pkgname%-bin}.sh")
+depends=(
+ 'electron22'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('556acfb66a0f37d7be1b838c37aa371228efd3655c6d212ac2ecd5749c9ec57a'
- 'd7992b859b00b218f3102b56cd1f038b89ef33a6fd3ac9b409e491c4c442ec06')
+ '7923440bf061d75d34e967f7f5ac538c0686ab0c23b2f522c8c6276ec823b36b')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/build/icons/"*.* -t "${pkgdir}/opt/${pkgname%-bin}/resources/build/icons"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/build/sounds/"*.wav -t "${pkgdir}/opt/${pkgname%-bin}/resources/build/sounds"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/build/icons/"*.* -t "${pkgdir}/usr/lib/${pkgname%-bin}/build/icons"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/build/sounds/"*.wav -t "${pkgdir}/usr/lib/${pkgname%-bin}/build/sounds"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/usr/share/icons/hicolor/256x256/apps/${pkgname%-bin}.png" -t"${pkgdir}/usr/share/pixmaps"
} \ No newline at end of file
diff --git a/whalebird.sh b/whalebird.sh
index 81f1e5dbd870..2f5f6e4a16ab 100644
--- a/whalebird.sh
+++ b/whalebird.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron22
-_ASAR="/opt/whalebird/resources/app.asar"
+APPDIR="/usr/lib/whalebird"
+export PATH="${APPDIR}:${PATH}"
+#export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else