summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2016-10-30 04:10:35 +0100
committerIlias Stamatis2016-10-30 04:10:35 +0100
commit8b0b706452be6c69536c2cea4a0ee7eb5eba1cd3 (patch)
tree96695e6adb3f2869563b258dee765f82c69dcf83
parent41979b30a7a58b9e65691863a2fea9a4e7dcf19c (diff)
downloadaur-8b0b706452be6c69536c2cea4a0ee7eb5eba1cd3.tar.gz
update Archlinux and ArchlinuxFull themes
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
-rw-r--r--archlinux.patch134
-rw-r--r--greeter.ui.ArchlinuxFull226
5 files changed, 148 insertions, 236 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdc26587f8ef..85fec3704187 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lxdm-themes
pkgdesc = Archlinux, ArchlinuxFull, ArchlinuxTop, Arch-Dark, Arch-Stripes and IndustrialArch lxdm themes
pkgver = 1
- pkgrel = 4
+ pkgrel = 5
url = https://wiki.archlinux.org/index.php/LXDM#Themes
install = lxdm-themes.install
arch = any
@@ -15,12 +15,14 @@ pkgbase = lxdm-themes
noextract = lxdm-theme.tar.gz
noextract = archlinux-lxdm.tar.gz
source = http://allanmcrae.com/files/lxdm-theme.tar.gz
- source = greeter.ui.ArchlinuxFull
+ source = archlinux.patch
+ source = git://github.com/redtide/lxdm-theme-archlinux.git
source = http://xdsl.hi2.ro/work/archlinux-lxdm.tar.gz
source = git+https://github.com/M4rQu1Nh0S/industrial-arch.git
source = https://dl.dropboxusercontent.com/u/33870708/lxdm-themes.tar.gz
sha256sums = 1eeaee69da8dd0ab28fc6967b06d4594980808bed83e822858a31b46926acbe7
- sha256sums = 09c66ccc6de32c6685b4f27cbfd2f2a2a679d4e961eebcbc80c294eb8d0f47d3
+ sha256sums = 1acd676a57525ca3cc6bc194dd5b7f2e942742016d8209ae4b76365bb440b734
+ sha256sums = SKIP
sha256sums = ad98f832de33909f321e87b10e0af2da156b91e0abf4b7e877e506dbed2fdd6e
sha256sums = SKIP
sha256sums = 2fa343b164b4ee6b1891bbf2eb52fc6605ee673323893b443fba32b46949f647
diff --git a/.gitignore b/.gitignore
index 96901459d94e..60fad254426f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*.tar.gz
*.pkg.tar.xz
industrial-arch/*
+lxdm-theme-archlinux/*
diff --git a/PKGBUILD b/PKGBUILD
index 5fe9d11ec5b4..9f014d15c592 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lxdm-themes
pkgver=1
-pkgrel=4
+pkgrel=5
pkgdesc="Archlinux, ArchlinuxFull, ArchlinuxTop, Arch-Dark, Arch-Stripes and IndustrialArch lxdm themes"
arch=(any)
url="https://wiki.archlinux.org/index.php/LXDM#Themes"
@@ -12,18 +12,19 @@ conflicts=('archlinux-lxdm-theme' 'archlinux-lxdm-theme-full'
'archlinux-lxdm-theme-top' 'industrial-arch-lxdm')
install=lxdm-themes.install
source=('http://allanmcrae.com/files/lxdm-theme.tar.gz' # Archlinux
- 'greeter.ui.ArchlinuxFull' # ArchlinuxFull
+ 'archlinux.patch'
+ 'git://github.com/redtide/lxdm-theme-archlinux.git' # ArchlinuxFull
'http://xdsl.hi2.ro/work/archlinux-lxdm.tar.gz' # ArchlinuxTop
'git+https://github.com/M4rQu1Nh0S/industrial-arch.git' # IndustrialArch
'https://dl.dropboxusercontent.com/u/33870708/lxdm-themes.tar.gz' # Arch-Dark, Arch-Stripes
)
noextract=('lxdm-theme.tar.gz' 'archlinux-lxdm.tar.gz')
sha256sums=('1eeaee69da8dd0ab28fc6967b06d4594980808bed83e822858a31b46926acbe7'
- '09c66ccc6de32c6685b4f27cbfd2f2a2a679d4e961eebcbc80c294eb8d0f47d3'
+ '1acd676a57525ca3cc6bc194dd5b7f2e942742016d8209ae4b76365bb440b734'
+ 'SKIP'
'ad98f832de33909f321e87b10e0af2da156b91e0abf4b7e877e506dbed2fdd6e'
'SKIP'
- '2fa343b164b4ee6b1891bbf2eb52fc6605ee673323893b443fba32b46949f647'
- )
+ '2fa343b164b4ee6b1891bbf2eb52fc6605ee673323893b443fba32b46949f647')
prepare() {
# avoid file conflicts by extracting themes in different directories
@@ -31,6 +32,7 @@ prepare() {
mkdir Archlinux ArchlinuxTop
bsdtar -xf lxdm-theme.tar.gz -C Archlinux
bsdtar -xf archlinux-lxdm.tar.gz -C ArchlinuxTop
+ patch -Np0 -i archlinux.patch
}
package() {
@@ -42,8 +44,7 @@ package() {
cd "$srcdir"
cp -r Archlinux "$themesdir"
- cp -a Archlinux/* "${themesdir}/ArchlinuxFull"
- cp greeter.ui.ArchlinuxFull "${themesdir}/ArchlinuxFull"
+ cp -r lxdm-theme-archlinux/Archlinux/* "${themesdir}/ArchlinuxFull"
cp -r ArchlinuxTop "$themesdir"
cp -a lxdm-themes/ArchDark/* "${themesdir}/Arch-Dark"
cp -a lxdm-themes/ArchStripes/* "${themesdir}/Arch-Stripes"
diff --git a/archlinux.patch b/archlinux.patch
new file mode 100644
index 000000000000..95006728d32e
--- /dev/null
+++ b/archlinux.patch
@@ -0,0 +1,134 @@
+--- Archlinux/greeter.ui.orig 2013-09-06 05:20:06.275790776 +0000
++++ Archlinux/greeter.ui 2013-09-06 05:20:46.822174050 +0000
+@@ -25,7 +25,7 @@
+ <object class="GtkAlignment" id="alignment1">
+ <property name="visible">True</property>
+ <property name="xscale">0</property>
+- <property name="yscale">0</property>
++ <property name="yscale">1</property>
+ <child>
+ <object class="GtkVBox" id="vbox2">
+ <property name="visible">True</property>
+@@ -34,6 +34,7 @@
+ <object class="GtkImage" id="image1">
+ <property name="visible">True</property>
+ <property name="pixbuf">panel.png</property>
++ <property name="yalign">0.8</property>
+ </object>
+ <packing>
+ <property name="position">0</property>
+@@ -42,6 +43,7 @@
+ <child>
+ <object class="GtkAlignment" id="alignment2">
+ <property name="visible">True</property>
++ <property name="yalign">0.1</property>
+ <property name="xscale">0</property>
+ <property name="yscale">0</property>
+ <child>
+@@ -101,6 +121,26 @@
+ <property name="visible">False</property>
+ <property name="spacing">6</property>
+ <child>
++ <object class="GtkImage" id="image2">
++ <property name="visible">True</property>
++ <!--<property name="pixbuf">session.png</property>-->
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">0</property>
++ </packing>
++ </child>
++ <child>
++ <object class="GtkLabel" id="label2">
++ <property name="visible">True</property>
++ <property name="label" translatable="yes">Desktop:</property>
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">1</property>
++ </packing>
++ </child>
++ <child>
+ <object class="GtkComboBoxEntry" id="sessions">
+ <property name="visible">True</property>
+ <property name="text_column">0</property>
+@@ -116,6 +156,79 @@
+ <property name="position">0</property>
+ </packing>
+ </child>
++ <child>
++ <object class="GtkHBox" id="lang_box">
++ <property name="visible">True</property>
++ <property name="spacing">6</property>
++ <child>
++ <object class="GtkImage" id="image3">
++ <property name="visible">True</property>
++ <!--<property name="pixbuf">lang.png</property>-->
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">0</property>
++ </packing>
++ </child>
++ <child>
++ <object class="GtkLabel" id="label_lang">
++ <property name="visible">True</property>
++ <property name="label" translatable="yes">Language:</property>
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">1</property>
++ </packing>
++ </child>
++ <child>
++ <object class="GtkComboBoxEntry" id="lang">
++ <property name="visible">True</property>
++ <property name="text_column">0</property>
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">2</property>
++ </packing>
++ </child>
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">1</property>
++ </packing>
++ </child>
++ <child>
++ <object class="GtkLabel" id="label_keyboard">
++ <property name="label" translatable="yes">Keyboard:</property>
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">2</property>
++ </packing>
++ </child>
++ <child>
++ <object class="GtkComboBoxEntry" id="keyboard">
++ <property name="text_column">0</property>
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="position">3</property>
++ </packing>
++ </child>
++ <child>
++ <object class="GtkButton" id="exit">
++ <property name="label">gtk-quit</property>
++ <property name="visible">True</property>
++ <property name="can_focus">True</property>
++ <property name="receives_default">True</property>
++ <property name="relief">none</property>
++ <property name="use_stock">True</property>
++ </object>
++ <packing>
++ <property name="expand">False</property>
++ <property name="pack_type">end</property>
++ <property name="position">4</property>
++ </packing>
++ </child>
+ </object>
+ </child>
+ </object>
diff --git a/greeter.ui.ArchlinuxFull b/greeter.ui.ArchlinuxFull
deleted file mode 100644
index 13003e4ec369..000000000000
--- a/greeter.ui.ArchlinuxFull
+++ /dev/null
@@ -1,226 +0,0 @@
-<?xml version="1.0"?>
-<interface>
- <!-- interface-requires gtk+ 2.12 -->
- <!-- interface-naming-policy project-wide -->
- <object class="GtkWindow" id="lxdm">
- <property name="decorated">False</property>
- <child>
- <object class="GtkVBox" id="vbox1">
- <property name="visible">True</property>
- <property name="orientation">vertical</property>
- <child>
- <object class="GtkLabel" id="time">
- <property name="visible">True</property>
- <property name="xalign">1</property>
- <property name="xpad">12</property>
- <property name="ypad">12</property>
- <property name="single_line_mode">True</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkAlignment" id="alignment1">
- <property name="visible">True</property>
- <property name="xscale">0</property>
- <property name="yscale">0</property>
- <child>
- <object class="GtkVBox" id="vbox2">
- <property name="visible">True</property>
- <property name="orientation">vertical</property>
- <child>
- <object class="GtkImage" id="image1">
- <property name="visible">True</property>
- <property name="pixbuf">panel.png</property>
- </object>
- <packing>
- <property name="position">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkAlignment" id="alignment2">
- <property name="visible">True</property>
- <property name="xscale">0</property>
- <property name="yscale">0</property>
- <child>
- <object class="GtkHBox" id="hbox3">
- <property name="visible">True</property>
- <property name="spacing">12</property>
- <child>
- <object class="GtkLabel" id="prompt">
- <property name="visible">True</property>
- <property name="label" translatable="yes">User:</property>
- <property name="yalign">0.2</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="fill">False</property>
- <property name="position">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkIconView" id="user_list">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="item-padding">1</property>
- <property name="margin">2</property>
- <property name="column-spacing">0</property>
- <property name="row-spacing">1</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="fill">False</property>
- <property name="position">1</property>
- </packing>
- </child>
- <child>
- <object class="GtkEntry" id="login_entry">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="invisible_char">&#x2022;</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="fill">False</property>
- <property name="position">1</property>
- </packing>
- </child>
- </object>
- </child>
- </object>
- <packing>
- <property name="position">1</property>
- </packing>
- </child>
- </object>
- </child>
- </object>
- <packing>
- <property name="position">1</property>
- </packing>
- </child>
- <child>
- <object class="GtkEventBox" id="bottom_pane">
- <property name="visible">True</property>
- <property name="app_paintable">True</property>
- <property name="visible_window">False</property>
- <child>
- <object class="GtkHBox" id="bottom_hbox">
- <property name="visible">True</property>
- <property name="border_width">6</property>
- <property name="spacing">12</property>
- <child>
- <object class="GtkHBox" id="sessions_box">
- <property name="visible">True</property>
- <property name="spacing">6</property>
- <child>
- <object class="GtkLabel" id="label2">
- <property name="visible">True</property>
- <property name="label" translatable="yes">Desktop:</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkComboBoxEntry" id="sessions">
- <property name="visible">True</property>
- <property name="text_column">0</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">2</property>
- </packing>
- </child>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkHBox" id="lang_box">
- <property name="visible">True</property>
- <property name="spacing">6</property>
- <child>
- <object class="GtkImage" id="image3">
- <property name="visible">True</property>
- <!--<property name="pixbuf">lang.png</property>-->
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkLabel" id="label_lang">
- <property name="visible">True</property>
- <property name="label" translatable="yes">Language:</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">1</property>
- </packing>
- </child>
- <child>
- <object class="GtkComboBoxEntry" id="lang">
- <property name="visible">True</property>
- <property name="text_column">0</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">2</property>
- </packing>
- </child>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">1</property>
- </packing>
- </child>
- <child>
- <object class="GtkLabel" id="label_keyboard">
- <property name="label" translatable="yes">Keyboard:</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">2</property>
- </packing>
- </child>
- <child>
- <object class="GtkComboBoxEntry" id="keyboard"/>
- <packing>
- <property name="expand">False</property>
- <property name="position">3</property>
- </packing>
- </child>
- <child>
- <object class="GtkButton" id="exit">
- <property name="label">gtk-quit</property>
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="receives_default">True</property>
- <property name="relief">none</property>
- <property name="use_stock">True</property>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="pack_type">end</property>
- <property name="position">4</property>
- </packing>
- </child>
- </object>
- </child>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="position">2</property>
- </packing>
- </child>
- </object>
- </child>
- </object>
-</interface>