summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2015-06-29 16:43:02 +0200
committerpancho horrillo2015-06-29 16:43:02 +0200
commit8b2d08dd0eb1ff76f657c0913eaaa99d097567da (patch)
treefd898f11fb41dbd74c782172d529896482f561fc
downloadaur-8b2d08dd0eb1ff76f657c0913eaaa99d097567da.tar.gz
Initial import, release 2.1-2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
-rw-r--r--pam_ssh.install78
3 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c366437147c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 4.2.1
+# Sun May 10 18:38:20 UTC 2015
+pkgbase = pam_ssh
+ pkgdesc = PAM module providing single sign-on behavior for SSH.
+ pkgver = 2.1
+ pkgrel = 2
+ url = http://pam-ssh.sourceforge.net/
+ install = pam_ssh.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = pam
+ depends = openssl
+ depends = openssh
+ options = !libtool
+ source = http://downloads.sf.net/sourceforge/pam-ssh/pam_ssh-2.1.tar.xz
+ source = http://downloads.sf.net/sourceforge/pam-ssh/pam_ssh-2.1.tar.xz.asc
+ source = pam_ssh.install
+ sha512sums = 8252b15efffa5687f740963f7a3c3479b73f99eca26a17155f915a10b9a71362a2778449adf10f01c174cc8545961ce3ea64459338a7c995c242b209529fd640
+ sha512sums = SKIP
+ sha512sums = 954f203926e1c559d6a1471cf8b547373673e7ae4bf00b936a3014f38f1f92a035ba2843e3340d7237e5bed7550d9a3dee99f57cd1d01e1697fc12b6ae6ae58b
+
+pkgname = pam_ssh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3352d6dc9390
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: pancho horrillo <pancho at pancho dot name>
+# Contributor: bender02 at archlinux dot us
+# Contributor: Troels Kofoed Jacobsen <tkjacobsen at gmail dot com>
+
+pkgname=pam_ssh
+pkgver=2.1
+pkgrel=2
+pkgdesc='PAM module providing single sign-on behavior for SSH.'
+arch=('i686' 'x86_64')
+url='http://pam-ssh.sourceforge.net/'
+license=('custom')
+depends=('pam' 'openssl' 'openssh')
+options=('!libtool')
+install=pam_ssh.install
+source=("http://downloads.sf.net/sourceforge/pam-ssh/$pkgname-$pkgver.tar.xz"{,.asc} "$pkgname.install")
+sha512sums=('8252b15efffa5687f740963f7a3c3479b73f99eca26a17155f915a10b9a71362a2778449adf10f01c174cc8545961ce3ea64459338a7c995c242b209529fd640'
+ 'SKIP'
+ '954f203926e1c559d6a1471cf8b547373673e7ae4bf00b936a3014f38f1f92a035ba2843e3340d7237e5bed7550d9a3dee99f57cd1d01e1697fc12b6ae6ae58b')
+validpgpkeys=('501B088D8485568B87BB62BE180F6A5B3EDE742E') # Wolfgang Rosenauer
+
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --with-pam-dir=/usr/lib/security
+ make
+}
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -m 644 -D COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/pam_ssh.install b/pam_ssh.install
new file mode 100644
index 000000000000..3862bd64f718
--- /dev/null
+++ b/pam_ssh.install
@@ -0,0 +1,78 @@
+_define () {
+ read -r -d '' ${1} || true
+}
+
+_define _CAVEAT_PRE_2_0 <<-'EOF'
+
+ CAVEAT EMPTOR: Backward incompatible change, requires manual intervention:
+
+ (See the abridged README and Changelog below).
+
+ To sum up:
+ . The "keyfiles" option has been removed. You should edit your /etc/pam.d/???
+ and remove it.
+
+ . If ~/.ssh/id(entity|_(r|d|ecd)sa) exist, those will be used.
+
+ . The module now also tries to authenticate against keys located in
+ ~/.ssh/login-keys.d/ (can be symlinks to the actual keys).
+
+ . Additional keys in ~/.ssh/session-keys.d/ will be loaded too.
+
+
+
+ Excerpt from pam_ssh 2.0 README:
+
+ Per-user setup
+ --------------
+
+ pam_ssh will try to decrypt the traditional SSH keys, that is, files
+ matching $HOME/.ssh/id(entity|_(r|d|ecd)sa). pam_ssh will also try to
+ decrypt all keys in the directories $HOME/.ssh/login-keys.d and
+ $HOME/.ssh/session-keys.d, and (if your system administrator has
+ configured your system thus) allow you to log in using any of these login
+ keys. So if you want to log in by using an SSH key passphrase, you should
+ create a login-keys.d directory and in this directory create (symbolic
+ links to) all the keys you want to use as login keys. Nevertheless keys
+ in the directory $HOME/.ssh/login-keys.d with .disabled or .frozen as
+ suffix are ignored. The handling for keys in $HOME/.ssh/session-keys.d
+ is similar bot those are not used for login purposes.
+
+
+ Excerpt from pam_ssh 2.0 Changelog:
+
+ Version 2.0 released
+ ====================
+
+ 2013-11-17 Wolfgang Rosenauer
+
+ * pam_ssh.c: search additional keys in directory session-keys.d
+ Users having alternative keys (non-default names) and want them
+ unlocked at login with the passphrase and added to the agent
+ can now put or link them into .ssh/session-keys.d directory
+
+
+ 2013-11-10 Wolfgang Rosenauer
+
+ [...]
+ * pam_get_pass.c, pam_get_pass.h, pam_ssh.c:
+ [...]
+ Look for SSH keys in $HOME/.ssh/login-keys.d/, given that SSH keys
+ with .disabled or .frozen as suffix are ignored.
+ "keyfiles" option has been removed
+EOF
+
+_is_older_than_2_0 () {
+ local pkg_ver="$1"
+
+ test $(vercmp "$pkg_ver" '2.0') -lt 0
+}
+
+post_upgrade () {
+ local new_pkg_ver="$1" # not used
+ local old_pkg_ver="$2"
+
+ if _is_older_than_2_0 $old_pkg_ver; then
+ echo "$_CAVEAT_PRE_2_0"
+ fi
+}