summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheunpleasantowl2018-08-28 01:40:50 -0400
committertheunpleasantowl2018-08-28 01:40:50 -0400
commit8b4182b17d707b99beb6f535071e0066800691f5 (patch)
treea7804b72bd63afea3e29050239949662c8df409a
downloadaur-8b4182b17d707b99beb6f535071e0066800691f5.tar.gz
Stage for AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9001569efd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gemas.app
+ pkgdesc = A simple code editor with highlight syntax and auto indentation
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://www.nongnu.org/gnustep-nonfsf/gemas/index.html
+ arch = i686
+ arch = x86_64
+ groups = gnustep-apps
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ depends = highlighterkit
+ source = http://download.savannah.nongnu.org/releases/gnustep-nonfsf/Gemas-0.4.tar.gz
+ sha256sums = db1709aac8ed4d5c609c19a922eb2d6ea518e5379a068dd03b2635970b4c59cd
+
+pkgname = gemas.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..108c083d5ddc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+pkgname=gemas.app
+_pkgname=Gemas
+pkgrel=1
+pkgver=0.4
+pkgdesc="A simple code editor with highlight syntax and auto indentation"
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/gnustep-nonfsf/gemas/index.html"
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back' 'highlighterkit')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://download.savannah.nongnu.org/releases/gnustep-nonfsf/Gemas-0.4.tar.gz")
+sha256sums=('db1709aac8ed4d5c609c19a922eb2d6ea518e5379a068dd03b2635970b4c59cd')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file