summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-10-19 08:32:03 -0600
committerMark Wagie2022-10-19 08:32:03 -0600
commit8bc095d04ab7d965f3dd9d02ba984f346c27af72 (patch)
treead1d5797c1bcb5b30cbb4e354bf30c1819ee5381
parent428b6c342a081418a08f44f0980898b8adab11fa (diff)
downloadaur-8bc095d04ab7d965f3dd9d02ba984f346c27af72.tar.gz
improve build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD44
2 files changed, 16 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4c9a7e3a114..90c70b5ad960 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bibata-cursor-theme
pkgdesc = Material Based Cursor Theme
pkgver = 2.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ful1e5/Bibata_Cursor
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 95b770c6757b..9855c4f84e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bibata-cursor-theme
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Material Based Cursor Theme"
arch=('any')
url="https://github.com/ful1e5/Bibata_Cursor"
@@ -21,35 +21,21 @@ prepare() {
build() {
cd Bibata_Cursor-$pkgver
- echo "Building 'Bibata Modern Amber' Cursors"
- ctgen build.toml -p 'x11' -n 'Bibata-Modern-Amber' \
- -c 'Yellowish and rounded edge Bibata cursors.' \
- -d 'bitmaps/Bibata-Modern-Amber'
- echo "Building 'Bibata Original Amber' Cursors"
- ctgen build.toml -p 'x11' -n 'Bibata-Original-Amber' \
- -c 'Yellowish and sharp edge Bibata cursors.' \
- -d 'bitmaps/Bibata-Original-Amber'
-
- echo "Building 'Bibata Modern Classic' Cursors"
- ctgen build.toml -p 'x11' -n 'Bibata-Modern-Classic' \
- -c 'Black and rounded edge Bibata cursors.' \
- -d 'bitmaps/Bibata-Modern-Classic'
-
- echo "Building 'Bibata Original Classic' Cursors"
- ctgen build.toml -p 'x11' -n 'Bibata-Original-Classic' \
- -c 'Black and sharp edge Bibata cursors.' \
- -d 'bitmaps/Bibata-Original-Classic'
-
- echo "Building 'Bibata Modern Ice' Cursors"
- ctgen build.toml -p 'x11' -n 'Bibata-Modern-Ice' \
- -c 'White and rounded edge Bibata cursors.' \
- -d 'bitmaps/Bibata-Modern-Ice'
-
- echo "Building 'Bibata Original Ice' Cursors"
- ctgen build.toml -p 'x11' -n 'Bibata-Original-Ice' \
- -c 'White and sharp edge bibata cursors.' \
- -d 'bitmaps/Bibata-Original-Ice'
+ declare -A names
+ names["Bibata-Modern-Amber"]="Yellowish and rounded edge Bibata cursors."
+ names["Bibata-Modern-Classic"]="Black and rounded edge Bibata cursors."
+ names["Bibata-Modern-Ice"]="White and rounded edge Bibata cursors."
+ names["Bibata-Original-Amber"]="Yellowish and sharp edge Bibata cursors."
+ names["Bibata-Original-Classic"]="Black and sharp edge Bibata cursors."
+ names["Bibata-Original-Ice"]="White and sharp edge Bibata cursors."
+
+ for key in "${!names[@]}"; do
+ comment="${names[$key]}";
+ ctgen build.toml -p x11 -d "bitmaps/$key" -n "$key" -c "$comment" &
+ PID=$!
+ wait $PID
+ done
}
package() {