summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShizcow2020-04-07 20:43:38 -0600
committerShizcow2020-04-07 20:43:38 -0600
commit8bc1a28b2c39d781ff04a46e279aa085b2932102 (patch)
treea5c48eede47bfb91306e33a7ec103d255e74f2f1
downloadaur-8bc1a28b2c39d781ff04a46e279aa085b2932102.tar.gz
It works usually
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24641c68eb79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = matrixise
+ pkgdesc = Turn anything into 'The Matrix' wallpaper
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/Shizcow/matrixise
+ arch = any
+ license = GPL2
+ makedepends = rust
+ makedepends = git
+ depends = ncurses
+ source = matrixise::git+https://github.com/Shizcow/matrixise.git
+ md5sums = SKIP
+
+pkgname = matrixise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7785fa3f926
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Devin Pohl <pohl.devin@gmail.com>
+
+pkgname=matrixise
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Turn anything into 'The Matrix' wallpaper"
+arch=('any')
+url="https://github.com/Shizcow/matrixise"
+license=('GPL2')
+depends=('ncurses')
+makedepends=('rust' 'git')
+source=(
+ "${pkgname}::git+${url}.git"
+)
+md5sums=('SKIP')
+build() (
+ cd matrixise
+ cargo build --release --examples
+)
+package() (
+ install -D -m 755 ${srcdir}/matrixise/target/release/examples/stdin ${pkgdir}/usr/bin/$pkgname
+) \ No newline at end of file