summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-08-19 00:23:35 -0700
committerSchala2016-08-19 00:23:35 -0700
commit8bfdb479c2fab3da6d67d9aa2ee58c0020614440 (patch)
tree211bde66cc5e3341441e775de99a31ae5106b8a5
parentda07d69283c030682963d8ed77ac0e4e7c898f39 (diff)
downloadaur-8bfdb479c2fab3da6d67d9aa2ee58c0020614440.tar.gz
keep EXEs
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4762080d14f3..b1e50b78dae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jun 21 07:54:10 UTC 2016
+# Fri Aug 19 07:23:18 UTC 2016
pkgbase = mingw-w64-libxslt
pkgdesc = XML stylesheet transformation library (mingw-w64)
pkgver = 1.1.29
- pkgrel = 1
+ pkgrel = 2
url = http://xmlsoft.org/XSLT
arch = any
license = custom
@@ -14,6 +14,7 @@ pkgbase = mingw-w64-libxslt
options = !strip
options = staticlibs
options = !buildflags
+ options = !emptydirs
source = http://xmlsoft.org/sources/libxslt-1.1.29.tar.gz
source = libxslt-1.1.26-w64.patch
source = libxslt-1.1.28-win32-shared.patch
diff --git a/PKGBUILD b/PKGBUILD
index 37f8d607dde3..4d76c945f3d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=mingw-w64-libxslt
pkgver=1.1.29
-pkgrel=1
+pkgrel=2
pkgdesc="XML stylesheet transformation library (mingw-w64)"
arch=(any)
url="http://xmlsoft.org/XSLT"
license=(custom)
depends=(mingw-w64-crt mingw-w64-libxml2 mingw-w64-libgcrypt)
makedepends=(mingw-w64-configure)
-options=(!strip staticlibs !buildflags)
+options=(!strip staticlibs !buildflags !emptydirs)
source=("http://xmlsoft.org/sources/libxslt-${pkgver}.tar.gz"
"libxslt-1.1.26-w64.patch"
"libxslt-1.1.28-win32-shared.patch"
@@ -46,10 +46,10 @@ package() {
for _arch in ${_architectures}; do
cd "$srcdir/libxslt-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
- rm -r "$pkgdir"/usr/${_arch}/share
- find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
- find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ #rm -r "$pkgdir"/usr/${_arch}/share
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}