summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-12-13 14:55:48 +0200
committerDimitris Kiziridis2020-12-13 14:55:48 +0200
commit8c035aca7f1c9b3a1e99d8655b90599a5ac82ab9 (patch)
tree35cfff1ccd9e488aceff813277eb4e95f1e69aec
parent1509a993f887505a5f4347778a78fe492a278f08 (diff)
downloadaur-8c035aca7f1c9b3a1e99d8655b90599a5ac82ab9.tar.gz
add new maintainer and provides array
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2049a8115f0..d95abd2f107a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cht.sh-git
pkgdesc = The only cheat sheet you need (command line client for cheat.sh)
- pkgver = r586.c4c3a62
- pkgrel = 2
+ pkgver = r819.d2b8697
+ pkgrel = 1
url = https://github.com/chubin/cheat.sh
arch = any
license = MIT
@@ -11,7 +11,7 @@ pkgbase = cht.sh-git
depends = rlwrap
conflicts = cht.sh
source = cht.sh-git::git+https://github.com/chubin/cheat.sh
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = cht.sh-git
diff --git a/PKGBUILD b/PKGBUILD
index c31ac5d8737b..12b302edc423 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Simon Legner <Simon.Legner@gmail.com
+
pkgname=cht.sh-git
-pkgver=r586.c4c3a62
-pkgrel=2
+pkgver=r819.d2b8697
+pkgrel=1
pkgdesc="The only cheat sheet you need (command line client for cheat.sh)"
arch=('any')
url='https://github.com/chubin/cheat.sh'
license=('MIT')
+provices=('cht.sh')
+conflicts=('cht.sh')
depends=('curl' 'xsel' 'rlwrap')
makedepends=('git')
-source=("$pkgname::git+https://github.com/chubin/cheat.sh")
-sha1sums=('SKIP')
-conflicts=('cht.sh')
+source=("${pkgname}::git+https://github.com/chubin/cheat.sh")
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$pkgname"
+ cd "${pkgname}"
install -Dm755 "share/cht.sh.txt" "$pkgdir/usr/bin/cht.sh"
install -Dm644 "share/bash_completion.txt" "$pkgdir/usr/share/bash-completion/completions/cht.sh"
install -Dm644 "share/fish.txt" "$pkgdir/usr/share/fish/vendor_completions.d/cht.sh.fish"
install -Dm644 "share/zsh.txt" "$pkgdir/usr/share/zsh/site-functions/_cht.sh"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}