summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaklon2024-04-29 20:55:44 +0100
committerDaklon2024-04-29 20:56:45 +0100
commit8c2c8e931799f6a1fb936717a0685f273ac4109c (patch)
tree7d80264e01038642ca70b0c91d0f4d46070dbc22
parent5a7f36aa0665da4363825c26f2f838ef0e3f3b19 (diff)
downloadaur-8c2c8e931799f6a1fb936717a0685f273ac4109c.tar.gz
Remove lxml and keyring upper version limits, adds gitignore. The package is working again
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD7
-rw-r--r--relax-keyring-version-constraints.patch14
-rw-r--r--relax-pyxdg-version-constraints.patch10
4 files changed, 20 insertions, 14 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e284218a15a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+*.tar.*
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index d43f9f962582..fa6a37430457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=openconnect-sso
pkgver=0.8.0
-pkgrel=5
+pkgrel=6
pkgdesc="Wrapper script for OpenConnect supporting Azure AD (SAMLv2) authentication"
arch=('any')
url="https://github.com/vlaci/openconnect-sso"
@@ -17,8 +17,9 @@ source=("https://github.com/vlaci/openconnect-sso/releases/download/v$pkgver/$pk
'relax-pyxdg-version-constraints.patch'
'relax-keyring-version-constraints.patch')
sha256sums=('a7bde0a8dd35d7bab3c66f28b420c343c270a7ee45e98e04bfa6ecc6958f5c5b'
- 'a74a597fe78299917a276d743b446d90e5677a234824952d2383582e4cdce63c'
- 'cb723f0e6d72338a893e40dcb186859e25c5f90c2fee7d933532082ea493c1ff')
+ '820cc200d62db90446f9102ddce2c2b166b5cc487e6ba0490ec3f62ad762bb31'
+ '1a06f5ae5ba7e8204b2b975402f080e7e04364a2cf102d9c6e172a16f268f0ab')
+
prepare() {
cd "$pkgname-$pkgver"
diff --git a/relax-keyring-version-constraints.patch b/relax-keyring-version-constraints.patch
index 8ffcefd96745..4f3c3b891503 100644
--- a/relax-keyring-version-constraints.patch
+++ b/relax-keyring-version-constraints.patch
@@ -18,8 +18,8 @@ index 453a21f..384f5ef 100644
Requires-Dist: colorama (>=0.4,<0.5)
Requires-Dist: importlib-metadata (>=3.10.0,<4.0.0); python_version < "3.8"
-Requires-Dist: keyring (>=21.1,<24.0.0)
-+Requires-Dist: keyring (>=21.1,<25.0.0)
- Requires-Dist: lxml (>=4.3,<5.0)
++Requires-Dist: keyring (>=21.1)
+ Requires-Dist: lxml (>=4.3)
Requires-Dist: prompt-toolkit (>=3.0.3,<4.0.0)
Requires-Dist: pyxdg (>=0.26,<0.28)
@@ -201,4 +201,3 @@ $ result/bin/openconnect-sso --help
@@ -36,9 +36,9 @@ index 040605f..42f6f0e 100644
importlib-metadata = { version = "^3.10.0", python = "<3.8" }
lxml = "^4.3"
-keyring = ">=21.1, <24.0.0"
-+keyring = ">=21.1, <25.0.0"
++keyring = ">=21.1"
prompt-toolkit = "^3.0.3"
- pyxdg = ">=0.26, <0.28"
+ pyxdg = ">=0.26, <0.29"
requests = "^2.22"
diff --git a/setup.py b/setup.py
index 4c08404..2b85c98 100644
@@ -49,10 +49,10 @@ index 4c08404..2b85c98 100644
'attrs>=18.2',
'colorama>=0.4,<0.5',
- 'keyring>=21.1,<24.0.0',
-+ 'keyring>=21.1,<25.0.0',
- 'lxml>=4.3,<5.0',
++ 'keyring>=21.1',
+ 'lxml>=4.3',
'prompt-toolkit>=3.0.3,<4.0.0',
- 'pyxdg>=0.26,<0.28',
+ 'pyxdg>=0.26,<0.29',
--
2.41.0
diff --git a/relax-pyxdg-version-constraints.patch b/relax-pyxdg-version-constraints.patch
index e9e167cc6e1f..a583e06095e6 100644
--- a/relax-pyxdg-version-constraints.patch
+++ b/relax-pyxdg-version-constraints.patch
@@ -15,7 +15,8 @@ index 57d1852..62493da 100644
+++ b/PKG-INFO
@@ -28,7 +28,7 @@ Requires-Dist: importlib-metadata (>=3.10.0,<4.0.0); python_version < "3.8"
Requires-Dist: keyring (>=21.1,<24.0.0)
- Requires-Dist: lxml (>=4.3,<5.0)
+-Requires-Dist: lxml (>=4.3,<5.0)
++Requires-Dist: lxml (>=4.3)
Requires-Dist: prompt-toolkit (>=3.0.3,<4.0.0)
-Requires-Dist: pyxdg (>=0.26,<0.28)
+Requires-Dist: pyxdg (>=0.26,<0.29)
@@ -28,7 +29,7 @@ index 040605f..2d0f19f 100644
+++ b/pyproject.toml
@@ -27,7 +27,7 @@ importlib-metadata = { version = "^3.10.0", python = "<3.8" }
lxml = "^4.3"
- keyring = ">=21.1, <24.0.0"
+ keyring = ">=21.1, <25.0.0"
prompt-toolkit = "^3.0.3"
-pyxdg = ">=0.26, <0.28"
+pyxdg = ">=0.26, <0.29"
@@ -39,9 +40,10 @@ diff --git a/setup.py b/setup.py
index 4c08404..42493a7 100644
--- a/setup.py
+++ b/setup.py
-@@ -14,7 +14,7 @@ install_requires = \
+@@ -14,7 +14,7 @@ 'colorama>=0.4,<0.5'
'keyring>=21.1,<24.0.0',
- 'lxml>=4.3,<5.0',
+- 'lxml>=4.3,<5.0',
++ 'lxml>=4.3',
'prompt-toolkit>=3.0.3,<4.0.0',
- 'pyxdg>=0.26,<0.28',
+ 'pyxdg>=0.26,<0.29',