summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-02 18:34:21 +0200
committersL1pKn072019-04-02 18:34:21 +0200
commit8c5363aa5e12128a2e5465b4cdac8ce6e2418b8f (patch)
treef70c2e0f4a2ad1691a522fa44407b0d941d53d47
parent71eed78c922e0cff2c8176deba2020794e5bc131 (diff)
downloadaur-8c5363aa5e12128a2e5465b4cdac8ce6e2418b8f.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--kf5.patch15
3 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c74868d98248..3d608fdf71b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 11 21:43:56 UTC 2018
+# Tue Apr 2 16:34:17 UTC 2019
pkgbase = dolphin-megasync-git
pkgdesc = Upload your files to your Mega account from Dolphin file manager. (GIT Version)
- pkgver = v3.6.0.0.1.ga8739fe3
+ pkgver = v4.0.2.0.1.g2dec1949
pkgrel = 1
url = https://mega.co.nz/sync
arch = x86_64
@@ -12,10 +12,11 @@ pkgbase = dolphin-megasync-git
makedepends = git
depends = kio
depends = hicolor-icon-theme
+ depends = megasync
source = git+https://github.com/meganz/MEGAsync.git
source = kf5.patch
sha256sums = SKIP
- sha256sums = d99c53c8a393e2b3896c55ccbffaec55d9ab439c0079485780c9388bf70eac6d
+ sha256sums = 9f356204e6c844216e68f2c75a7d757c46a811130793fe2a4238e19d05d2da0f
pkgname = dolphin-megasync-git
diff --git a/PKGBUILD b/PKGBUILD
index f53e03e0180c..adcd6492dd7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=dolphin-megasync-git
-pkgver=v3.6.0.0.1.ga8739fe3
+pkgver=v4.0.2.0.1.g2dec1949
pkgrel=1
pkgdesc="Upload your files to your Mega account from Dolphin file manager. (GIT Version)"
arch=('x86_64')
@@ -9,6 +9,7 @@ url='https://mega.co.nz/sync'
license=('custom:MEGA')
depends=('kio'
'hicolor-icon-theme'
+ 'megasync'
)
makedepends=('extra-cmake-modules'
'qt5-tools'
@@ -18,18 +19,18 @@ source=('git+https://github.com/meganz/MEGAsync.git'
'kf5.patch'
)
sha256sums=('SKIP'
- 'd99c53c8a393e2b3896c55ccbffaec55d9ab439c0079485780c9388bf70eac6d'
+ '9f356204e6c844216e68f2c75a7d757c46a811130793fe2a4238e19d05d2da0f'
)
pkgver() {
cd MEGAsync
- echo "$(git describe --long --tags | tr - . | tr _ . | sed 's|OSX\.||' | sed 's|Win\.||' | sed 's|Linux\.||' )"
+ echo "$(git describe --long --tags | tr - . | tr _ . | sed 's|OSX\.||' | sed 's|Win\.||' | sed 's|Linux\.||' | sed 's|Ubuntu\.18\.10build\.||g' )"
}
prepare() {
mkdir -p build
- patch -p1 -i ${srcdir}/kf5.patch
+ patch -p1 -i "${srcdir}/kf5.patch"
mv MEGAsync/src/MEGAShellExtDolphin/CMakeLists.txt MEGAsync/src/MEGAShellExtDolphin/CMakeLists.txt.old
mv MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt MEGAsync/src/MEGAShellExtDolphin/CMakeLists.txt
@@ -38,6 +39,7 @@ prepare() {
build() {
cd build
cmake ../MEGAsync/src/MEGAShellExtDolphin \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -46,4 +48,6 @@ build() {
package() {
make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 MEGAsync/LICENCE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE.md"
}
diff --git a/kf5.patch b/kf5.patch
index 3b18ae6995c5..1eea2f28cfef 100644
--- a/kf5.patch
+++ b/kf5.patch
@@ -1,23 +1,12 @@
diff --git a/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt b/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt
-index 83224966..3814d073 100644
---- a/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt
-+++ b/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt
-@@ -38,7 +38,6 @@ add_definitions(-DWITH_KF5)
- if (KF5_VERSION)
- if (NOT KF5_VERSION VERSION_LESS 5.16.0)
- set(MEGASYNCDOLPHINOVERLAYPLUGIN megasyncdolphinoverlayplugin)
-- set(PLUGIN_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/qt5/plugins) #so that kcoreaddons install in the right path (see https://github.com/KDE/kcoreaddons/blob/master/KF5CoreAddonsMacros.cmake)
- kcoreaddons_add_plugin(${MEGASYNCDOLPHINOVERLAYPLUGIN} INSTALL_NAMESPACE "kf5/overlayicon"
- JSON megasync-plugin-overlay.json SOURCES megasync-plugin-overlay.cpp)
- #target_link_libraries(${MEGASYNCDOLPHINOVERLAYPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWidgets ${MEGASYNCDOLPHINHELPER})
-@@ -60,5 +61,6 @@ target_link_libraries(${MEGASYNCPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWid
+@@ -63,5 +64,6 @@ target_link_libraries(${MEGASYNCPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWid
#configure_file(megasync-plugin.desktop.in ${MEGASYNCPLUGIN}.desktop ESCAPE_QUOTES @ONLY)
#install(FILES ${CMAKE_CURRENT_BINARY_DIR}/megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
+#install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${CMAKE_INSTALL_LIBDIR}/qt5/plugins)
install(FILES megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
-+install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${PLUGIN_INSTALL_DIR})
-install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${CMAKE_INSTALL_LIBDIR}/qt5/plugins)
++install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${PLUGIN_INSTALL_DIR})
diff --git a/MEGAsync/src/MEGAShellExtDolphin/megasync-plugin.moc b/src/MEGAShellExtDolphin/megasync-plugin.moc
deleted file mode 100644