summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182020-12-22 17:50:26 +0100
committerLukas18182020-12-22 17:50:26 +0100
commit8c753ebd78f5791dd4072f08d52117b76b73d09f (patch)
treecd0c8b32daef36209fb60b25dc1bafed7233e373
downloadaur-8c753ebd78f5791dd4072f08d52117b76b73d09f.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
-rwxr-xr-xShortest Trip to Earth.desktop8
-rwxr-xr-xstart-shortest-trip-to-earth.sh3
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a962aa2c5c96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gog-shortest-trip-to-earth
+ pkgdesc = a roguelike spaceship simulator featuring exploration, ship management, game-influencing decision-making and real-time tactical battles
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://www.gog.com/game/shortest_trip_to_earth
+ arch = x86_64
+ groups = gog
+ groups = games
+ license = custom
+ makedepends = lgogdownloader
+ depends = gtk2
+ depends = bash
+ source = shortest_trip_to_earth_1_3_2.sh::gogdownloader://1911995101/en3installer0
+ source = Shortest Trip to Earth.desktop
+ source = start-shortest-trip-to-earth.sh
+ sha512sums = 31adc55bef75cc7ad4b188bb97b49bcee9e74fd176f44a9d795a0f44894198ec5e95fdbd2568aa22cafc559d5b0b29d2d3bb848975b3e0336a18aa92d33075ef
+ sha512sums = ec744a0f995ea5d746cf496d54e0a822b7d366c4c6cdff687163ceb0e876b11ee1b8307f19a74b0445414f096160c006537d8d46fc1d40c878bb716e281f93f1
+ sha512sums = a0d8350d6bb2c1778e032052a85932227ee491a863ba7ed82fc09eaefad9bd380a2fdd573a16e049c6a2a277ad4ccb06b14c6287d8a2bc7d9841dd39225aa988
+
+pkgname = gog-shortest-trip-to-earth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21915a6d507d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lukas1818 aur at lukas1818 dot de
+
+pkgname=gog-shortest-trip-to-earth
+pkgver=1.3.2
+_pkgtag=$pkgver
+pkgrel=1
+pkgdesc="a roguelike spaceship simulator featuring exploration, ship management, game-influencing decision-making and real-time tactical battles"
+arch=('x86_64')
+url="https://www.gog.com/game/$(echo ${pkgname//-/_} | cut -c 5-)"
+license=('custom')
+groups=('gog' 'games')
+makedepends=('lgogdownloader')
+depends=('gtk2' 'bash')
+source=("$(echo ${pkgname//-/_} | cut -c 5-)_${pkgver//./_}.sh::gogdownloader://1911995101/en3installer0"
+ "Shortest Trip to Earth.desktop"
+ "start-${pkgname:4}.sh")
+sha512sums=('31adc55bef75cc7ad4b188bb97b49bcee9e74fd176f44a9d795a0f44894198ec5e95fdbd2568aa22cafc559d5b0b29d2d3bb848975b3e0336a18aa92d33075ef'
+ 'ec744a0f995ea5d746cf496d54e0a822b7d366c4c6cdff687163ceb0e876b11ee1b8307f19a74b0445414f096160c006537d8d46fc1d40c878bb716e281f93f1'
+ 'a0d8350d6bb2c1778e032052a85932227ee491a863ba7ed82fc09eaefad9bd380a2fdd573a16e049c6a2a277ad4ccb06b14c6287d8a2bc7d9841dd39225aa988')
+
+DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+
+package()
+{
+ mkdir -p "${pkgdir}/opt/$pkgname"
+ mv "${srcdir}/data/noarch/game" -T "${pkgdir}/opt/$pkgname"
+ chmod -R 644 "${pkgdir}/opt/$pkgname/"
+ chmod 755 "${pkgdir}/opt/$pkgname/STEarth"
+ find "${pkgdir}/opt/$pkgname" -type d -exec chmod 755 {} \;
+ install -Dm 755 "${srcdir}/start-${pkgname:4}.sh" "${pkgdir}/usr/bin/${pkgname:4}"
+ install -Dm 755 "${srcdir}/Shortest Trip to Earth.desktop" "$pkgdir/usr/share/applications/Shortest Trip to Earth.desktop"
+ install -Dm 644 "${srcdir}/data/noarch/support/icon.png" "${pkgdir}/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "${srcdir}/data/noarch/docs/End User License Agreement.txt" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/Shortest Trip to Earth.desktop b/Shortest Trip to Earth.desktop
new file mode 100755
index 000000000000..0ecfc17bd9d1
--- /dev/null
+++ b/Shortest Trip to Earth.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Shortest Trip to Earth
+Exec=shortest-trip-to-earth
+Comment=a roguelike spaceship simulator featuring exploration, ship management, game-influencing decision-making and real-time tactical battles
+Terminal=false
+Icon=/usr/share/pixmaps/gog-shortest-trip-to-earth.png
+Type=Application
+Categories=Game;
diff --git a/start-shortest-trip-to-earth.sh b/start-shortest-trip-to-earth.sh
new file mode 100755
index 000000000000..9662c70ff0de
--- /dev/null
+++ b/start-shortest-trip-to-earth.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/gog-shortest-trip-to-earth
+./STEarth