summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeal Miller2020-03-21 22:03:56 -0500
committerNeal Miller2020-03-21 22:03:56 -0500
commit8c966fdebebe1c8e210f082c089b223335cb24d9 (patch)
tree8db3e503c6b242c03ec01d1cb0431d515a37930d
parentb721e81ba78e8393c41e265f901f849d5e5d54e4 (diff)
downloadaur-8c966fdebebe1c8e210f082c089b223335cb24d9.tar.gz
Add patch for QT 5.14, issue with Qhash, temporary. See https://groups.io/g/WSJTX/topic/71254545\?p\=Created,,,20,2,0,0::recentpostdate%2Fsticky,,,20,2,20,71254545
Signed-off-by: Neal Miller <meltdown03@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--wsjtx.patch19
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1df6c0ae5968..6a5adbfbaf6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wsjtx-superbuild-git
pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) - Superbuild/git version, hamlib not required
pkgver = r35.491536f
- pkgrel = 2
+ pkgrel = 3
url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
arch = i686
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = wsjtx-superbuild-git
source = wsjtx.patch
source = repo.patch
md5sums = SKIP
- md5sums = c5a2c0b91c2709e070d7ebcb75621354
+ md5sums = f50bfe0cb3d7bf91ee9b6b6302b78d65
md5sums = d7446a4c8d44880b1c772493a7f170c6
pkgname = wsjtx-superbuild-git
diff --git a/PKGBUILD b/PKGBUILD
index 06aa9ba55554..5864de00ee31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wsjtx-superbuild-git
pkgver=r35.491536f
-pkgrel=2
+pkgrel=3
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) - Superbuild/git version, hamlib not required'
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
@@ -15,7 +15,7 @@ source=('git+https://git.code.sf.net/p/wsjt/wsjtx-superbuild/'
'wsjtx.patch'
'repo.patch')
md5sums=('SKIP'
- 'c5a2c0b91c2709e070d7ebcb75621354'
+ 'f50bfe0cb3d7bf91ee9b6b6302b78d65'
'd7446a4c8d44880b1c772493a7f170c6')
#set branch to build with WSJTX_TAG variable, or a specific version eg. wsjtx-1.9.0
_wsjtx_tag=wsjtx-2.1.2
diff --git a/wsjtx.patch b/wsjtx.patch
index 9b8e043ab3dd..41db48728059 100644
--- a/wsjtx.patch
+++ b/wsjtx.patch
@@ -21,3 +21,22 @@ diff -ur /CMakeLists.txt /CMakeLists.txt
generate_export_header (wsjtx_udp-static BASE_NAME udp)
add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})
+
+--- a/qt_helpers.hpp 2019-11-26 09:22:32.000000000 -0500
++++ b/qt_helpers.hpp 2020-02-03 11:30:07.488214336 -0500
+@@ -83,6 +83,7 @@
+ // std::hash<> specialization for QString based on the dbj2
+ // algorithm <http://www.cse.yorku.ca/~oz/hash.html> because qHash()
+ // is poor on 64-bit platforms due to being a 32-bit hash value
++ #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
+ template<>
+ struct hash<QString>
+ {
+@@ -96,6 +97,7 @@
+ return hash;
+ }
+ };
++#endif
+ }
+
+ // Register some useful Qt types with QMetaType