summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Ray Mahardhika2017-07-28 05:23:09 +0700
committerMario Ray Mahardhika2017-07-28 05:23:09 +0700
commit8cc1fbf4b8345df70e2237dd94229a89fdf78eb5 (patch)
tree818ba0e2667236ccb0b363cf1cbe4acbd5886709
downloadaur-8cc1fbf4b8345df70e2237dd94229a89fdf78eb5.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
-rw-r--r--karlyriceditor.install4
-rw-r--r--openssl-1.1.X.patch44
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a24b05bfe0ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Jul 27 22:20:42 UTC 2017
+pkgbase = karlyriceditor
+ pkgdesc = A program which lets you edit and synchronize lyrics with karaoke songs in various formats.
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://www.ulduzsoft.com/linux/karaoke-lyrics-editor/
+ install = karlyriceditor.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = desktop-file-utils
+ source = openssl-1.1.X.patch
+ source = karlyriceditor-2.2.tar.gz::https://sourceforge.net/projects/karlyriceditor/files/2.2/karlyriceditor-2.2.tar.gz/download?nowrap
+ md5sums = 7d510835a99d36362b7ba0cb81e734a8
+ md5sums = b59ac716a34bfb07e0c21cd61e01ca9e
+
+pkgname = karlyriceditor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51f2f2059055
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mario Ray Mahardhika <leledumbo_cool@yahoo.co.id>
+pkgname=karlyriceditor
+pkgver=2.2
+pkgrel=1
+pkgdesc="A program which lets you edit and synchronize lyrics with karaoke songs in various formats."
+arch=('i686' 'x86_64')
+url="https://www.ulduzsoft.com/linux/karaoke-lyrics-editor/"
+license=('GPL')
+depends=('qt5-base' 'desktop-file-utils')
+source=('openssl-1.1.X.patch' "karlyriceditor-$pkgver.tar.gz::https://sourceforge.net/projects/karlyriceditor/files/$pkgver/karlyriceditor-$pkgver.tar.gz/download?nowrap")
+md5sums=('7d510835a99d36362b7ba0cb81e734a8' 'b59ac716a34bfb07e0c21cd61e01ca9e')
+install=$pkgname.install
+
+build() {
+ patch -p0 < openssl-1.1.X.patch
+ cd karlyriceditor-$pkgver
+ qmake
+ make
+}
+
+package() {
+ cd karlyriceditor-$pkgver
+ install -Dm755 bin/karlyriceditor $pkgdir/usr/bin/karlyriceditor
+ install -Dm644 packages/karlyriceditor.desktop $pkgdir/usr/share/applications/karlyriceditor.desktop
+ install -Dm644 packages/karlyriceditor.png $pkgdir/usr/share/pixmaps/karlyriceditor.png
+} \ No newline at end of file
diff --git a/karlyriceditor.install b/karlyriceditor.install
new file mode 100644
index 000000000000..9e1549ef50ba
--- /dev/null
+++ b/karlyriceditor.install
@@ -0,0 +1,4 @@
+postinstall() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor
+ update-desktop-database -q
+} \ No newline at end of file
diff --git a/openssl-1.1.X.patch b/openssl-1.1.X.patch
new file mode 100644
index 000000000000..6b7160a1e799
--- /dev/null
+++ b/openssl-1.1.X.patch
@@ -0,0 +1,44 @@
+diff -ruN karlyriceditor-2.2/src/kfn_file_parser.cpp karlyriceditor-2.2-fixed/src/kfn_file_parser.cpp
+--- karlyriceditor-2.2/src/kfn_file_parser.cpp 2013-02-05 08:52:34.795945000 +0700
++++ karlyriceditor-2.2-fixed/src/kfn_file_parser.cpp 2017-07-11 02:04:10.331059063 +0700
+@@ -314,10 +314,9 @@
+
+ #if defined (KFN_SUPPORT_ENCRYPTION)
+ // A file is encrypted, decrypt it
+- EVP_CIPHER_CTX ctx;
+- EVP_CIPHER_CTX_init( &ctx );
++ EVP_CIPHER_CTX *ctx = EVP_CIPHER_CTX_new();
+
+- EVP_DecryptInit_ex( &ctx, EVP_aes_128_ecb(), 0, (const unsigned char*) m_aesKey.data(), 0 );
++ EVP_DecryptInit_ex( ctx, EVP_aes_128_ecb(), 0, (const unsigned char*) m_aesKey.data(), 0 );
+
+ QByteArray array( entry.length_out, 0 );
+ int total_in = 0, total_out = 0;
+@@ -335,15 +334,15 @@
+
+ if ( bytesRead != toRead )
+ {
+- EVP_CIPHER_CTX_cleanup( &ctx );
++ EVP_CIPHER_CTX_free(ctx);
+ m_errorMsg = "File truncated";
+ return QByteArray();
+ }
+
+ // Decrypt the content
+- if ( !EVP_DecryptUpdate( &ctx, (unsigned char*) outbuf, &toWrite, (unsigned char*) buffer, bytesRead ) )
++ if ( !EVP_DecryptUpdate( ctx, (unsigned char*) outbuf, &toWrite, (unsigned char*) buffer, bytesRead ) )
+ {
+- EVP_CIPHER_CTX_cleanup( &ctx );
++ EVP_CIPHER_CTX_free(ctx);
+ m_errorMsg = "Decryption failed";
+ return QByteArray();
+ }
+@@ -353,7 +352,7 @@
+ total_in += bytesRead;
+ }
+
+- EVP_CIPHER_CTX_cleanup( &ctx );
++ EVP_CIPHER_CTX_free(ctx);
+ return array;
+ #else
+ m_errorMsg = "File is encrypted, but decryption support is not compiled in";