summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblack2016-10-07 21:02:35 +0200
committerblack2016-10-07 21:02:35 +0200
commit8cc4e913560f7e9d29fbdffb27e94744c0be0b8c (patch)
tree1fd7941652a7cda6077f59e3c7e45c0006995c1c
downloadaur-8cc4e913560f7e9d29fbdffb27e94744c0be0b8c.tar.gz
version 2.3.8
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5903f284a88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-spotipy
+ pkgdesc = Simple client for the Spotify Web API
+ pkgver = 2.3.8
+ pkgrel = 1
+ url = https://github.com/plamere/spotipy
+ arch = any
+ license = MIT
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-requests>=1.0
+ source = https://pypi.org/packages/source/s/spotipy/spotipy-2.3.8.tar.gz
+ md5sums = 0248576e241f74f08297dd7c76b0cc67
+
+pkgname = python2-spotipy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7adebbfdd03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=python2-spotipy
+_pkgname=spotipy
+pkgver=2.3.8
+pkgrel=1
+pkgdesc='Simple client for the Spotify Web API'
+arch=('any')
+url="https://github.com/plamere/spotipy"
+license=('MIT')
+depends=('python2' 'python2-requests>=1.0')
+makedepends=('python2' 'python2-setuptools')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+
+md5sums=('0248576e241f74f08297dd7c76b0cc67')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}