summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex2023-02-27 17:16:38 +0100
committerAlex2023-02-27 17:16:38 +0100
commit8cd75ebfb489feebd7902096f7f4b4d961c6c91b (patch)
tree081d71623415e4c7f4be1976e579e95afe40347b
parent5297188fa2ea668767233be8fcdcc634f0426c2c (diff)
downloadaur-8cd75ebfb489feebd7902096f7f4b4d961c6c91b.tar.gz
chore: update PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b2afa8b4450..52c0b6061786 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,45 @@
pkgbase = waybar-git
pkgdesc = Highly customizable Wayland bar for Sway and Wlroots based compositors (GIT)
- pkgver = r636.67593b8
+ pkgver = r2429.09142fa3
pkgrel = 1
url = https://github.com/Alexays/Waybar/
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
+ makedepends = catch2
makedepends = meson
makedepends = scdoc
makedepends = wayland-protocols
depends = gtkmm3
depends = libjsoncpp.so
- depends = libinput
depends = libsigc++
depends = fmt
+ depends = jack
+ depends = libjack.so
depends = wayland
- depends = chrono-date
+ depends = libdate-tz.so
depends = libspdlog.so
depends = gtk-layer-shell
+ depends = libupower-glib.so
+ depends = upower
+ depends = libevdev
+ depends = libinput
depends = libpulse
depends = libnl
depends = libappindicator-gtk3
depends = libdbusmenu-gtk3
depends = libmpdclient
+ depends = libsndio.so
+ depends = libxkbcommon
+ depends = libwireplumber
+ depends = playerctl
optdepends = otf-font-awesome: Icons in the default configuration
provides = waybar
conflicts = waybar
+ backup = etc/xdg/waybar/config
+ backup = etc/xdg/waybar/style.css
source = waybar-git::git+https://github.com/Alexays/Waybar
sha1sums = SKIP
pkgname = waybar-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6e44c1697b69..d31a1f314184 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexis Rouillard <contact@arouillard.fr>
pkgname=waybar-git
-pkgver=r636.67593b8
+pkgver=r2429.09142fa3
pkgrel=1
pkgdesc='Highly customizable Wayland bar for Sway and Wlroots based compositors (GIT)'
arch=('x86_64')
@@ -12,26 +12,39 @@ conflicts=('waybar')
depends=(
'gtkmm3'
'libjsoncpp.so'
- 'libinput'
'libsigc++'
'fmt'
+ 'jack' 'libjack.so'
'wayland'
- 'chrono-date'
+ 'libdate-tz.so'
'libspdlog.so'
'gtk-layer-shell'
+ 'libupower-glib.so'
+ 'upower'
+ 'libevdev'
+ 'libinput'
'libpulse'
'libnl'
'libappindicator-gtk3'
'libdbusmenu-gtk3'
'libmpdclient'
+ 'libsndio.so'
+ 'libxkbcommon'
+ 'libwireplumber'
+ 'playerctl'
)
makedepends=(
'git'
'cmake'
+ 'catch2'
'meson'
'scdoc' # For generating manpages
'wayland-protocols'
)
+backup=(
+ etc/xdg/waybar/config
+ etc/xdg/waybar/style.css
+)
optdepends=(
'otf-font-awesome: Icons in the default configuration'
)