summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 12:40:04 +1000
committerPhillip Smith2015-06-02 12:40:04 +1000
commit8d1dfc69a3b7c659d476b8dec0980e3b7de3588f (patch)
treedfc4d92145f83ee96dc0ef36e86a8d934e3db511
downloadaur-8d1dfc69a3b7c659d476b8dec0980e3b7de3588f.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
-rw-r--r--setup.patch39
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a19353f7ebb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = umit
+ pkgdesc = A powerful nmap frontend.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.umitproject.org/
+ arch = i686
+ arch = x86_64
+ arch = ppc
+ license = GPL
+ makedepends = python2
+ depends = python2
+ depends = pygtk
+ depends = nmap
+ depends = python2-pysqlite
+ source = http://downloads.sourceforge.net/umit/umit-1.0.tar.bz2
+ source = setup.patch
+ md5sums = 68412d8d50dafd53e0392f71ed62dcfc
+ md5sums = a1e1b57443c92e716b881bdb347fe091
+
+pkgname = umit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37282f91107f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/umit-*.pkg.tar.xz
+/umit-*.tar.bz2
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3fd3e9a8339
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: Haoyu Bai <baihaoyu@gmail.com>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=umit
+pkgver=1.0
+pkgrel=1
+pkgdesc="A powerful nmap frontend."
+arch=('i686' 'x86_64' 'ppc')
+url="http://www.umitproject.org/"
+license=('GPL')
+depends=('python2' 'pygtk' 'nmap' 'python2-pysqlite')
+makedepends=('python2')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
+ 'setup.patch')
+md5sums=('68412d8d50dafd53e0392f71ed62dcfc'
+ 'a1e1b57443c92e716b881bdb347fe091')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ patch -p0 < "$srcdir"/setup.patch
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ python2 setup.py install --root="$pkgdir" --install-lib=usr/share/umit
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..34788cbef233
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,39 @@
+*** setup.py.orig 2009-08-02 17:16:31.425667179 +0800
+--- setup.py 2009-08-02 17:18:53.985653155 +0800
+***************
+*** 266,273 ****
+
+ self.set_perms()
+ self.set_modules_path()
+! self.fix_paths()
+! self.create_uninstaller()
+ self.finish_banner()
+
+ def create_uninstaller(self):
+--- 266,273 ----
+
+ self.set_perms()
+ self.set_modules_path()
+! #self.fix_paths()
+! #self.create_uninstaller()
+ self.finish_banner()
+
+ def create_uninstaller(self):
+***************
+*** 330,336 ****
+ if self.pkgmaintainer and self.root:
+ modules = os.path.join('/', modules[len(self.root):])
+
+! ucontent.insert(uline, "sys.path.insert(0,'%s')\n" % modules)
+
+ ufile = open(umit, "w")
+ ufile.writelines(ucontent)
+--- 330,337 ----
+ if self.pkgmaintainer and self.root:
+ modules = os.path.join('/', modules[len(self.root):])
+
+! modules = "/usr/share/umit"
+! ucontent.insert(uline, "sys.path = ['%s'] + sys.path\n" % modules)
+
+ ufile = open(umit, "w")
+ ufile.writelines(ucontent)