summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis Horgix Chotard2018-06-08 00:14:30 +0200
committerAlexis Horgix Chotard2018-06-08 00:14:30 +0200
commit8d380f2aa2ef0fea5e2193593196a4ab51dd5ae6 (patch)
tree5765281156b59e5f1804a4ad2b85e1195d510314
downloadaur-8d380f2aa2ef0fea5e2193593196a4ab51dd5ae6.tar.gz
Initial commit: version 1.8.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fd6be685b0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jun 7 22:14:12 UTC 2018
+pkgbase = scalingo-cli
+ pkgdesc = Scalingo (https://scalingo.com/) Command Line Interface - compile from source
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://github.com/Scalingo/cli
+ arch = any
+ license = BSD
+ makedepends = go
+ makedepends = godep
+ conflicts = scalingo-cli-bin
+ source = scalingo-cli-1.8.0.tar.gz::https://github.com/Scalingo/cli/archive/1.8.0.tar.gz
+ sha256sums = 570cdaccefd2bd06d7228701b3509d7ab3343ac28e940f163c22396f58ba9650
+
+pkgname = scalingo-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83316b9e0082
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexis "Horgix" Chotard <alexis.horgix.chotard@gmail.com>
+
+pkgname=scalingo-cli
+_pkgname=scalingo
+pkgver=1.8.0
+pkgrel=1
+conflicts=('scalingo-cli-bin')
+pkgdesc="Scalingo (https://scalingo.com/) Command Line Interface - compile from source"
+arch=('any')
+url="https://github.com/Scalingo/cli"
+license=('BSD')
+makedepends=('go' 'godep')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/Scalingo/cli/archive/$pkgver.tar.gz")
+sha256sums=('570cdaccefd2bd06d7228701b3509d7ab3343ac28e940f163c22396f58ba9650')
+
+prepare() {
+ mkdir -p "$srcdir/go/src/github.com/Scalingo"
+}
+
+build() {
+ cp $srcdir/cli-$pkgver/LICENSE .
+ export GOPATH="$srcdir/go"
+ mv "cli-$pkgver" "$srcdir/go/src/github.com/Scalingo/cli"
+
+ cd "$srcdir/go/src/github.com/Scalingo/cli"
+ godep get ./scalingo
+ cd "$srcdir"
+ go build github.com/Scalingo/cli/scalingo
+}
+
+package() {
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ # To be included in later version
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}