summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-07-04 21:13:03 +0200
committeranthraxx2016-07-04 21:13:03 +0200
commit8d52913c71d5ad620fb4c18989c75064b692b2aa (patch)
treefbf9c587f6d1a4e61ba5eaa8577cc7936c235fac
downloadaur-8d52913c71d5ad620fb4c18989c75064b692b2aa.tar.gz
addpkg: hashcat-git 3.00.1210.30919d4-1
- adds makefile patch to preserve CFLAGS and LDFLAGS
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD47
-rw-r--r--makefile.patch41
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ab83235d14c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Mon Jul 4 19:13:03 UTC 2016
+pkgbase = hashcat-git
+ pkgdesc = A multithreaded cross platform hash cracker
+ pkgver = 3.00.1210.30919d4
+ pkgrel = 1
+ url = https://hashcat.net/hashcat
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = opencl-headers
+ depends = gmp
+ depends = libcl
+ optdepends = libxnvctrl: NVIDIA X driver configuration support
+ optdepends = opencl-nvidia: OpenCL support for NVIDIA
+ optdepends = opencl-mesa: OpenCL support for AMD/ATI Radeon mesa drivers
+ provides = hashcat
+ conflicts = hashcat
+ source = hashcat-git::git+https://github.com/hashcat/hashcat
+ source = makefile.patch
+ sha512sums = SKIP
+ sha512sums = be389cce5f325437b965c755819c09d6b997c534caebd74a947659f8d950e9b3cee365c993928c5522188e53412156eb64218dd844952125de96e7b764716a7d
+
+pkgname = hashcat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff75d27b9f19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Sam Stuewe <halosghost at archlinux dot info>
+
+pkgname=hashcat-git
+pkgver=3.00.1210.30919d4
+pkgrel=1
+pkgdesc='A multithreaded cross platform hash cracker'
+url='https://hashcat.net/hashcat'
+arch=('i686' 'x86_64')
+depends=('gmp' 'libcl')
+optdepends=('libxnvctrl: NVIDIA X driver configuration support'
+ 'opencl-nvidia: OpenCL support for NVIDIA'
+ 'opencl-mesa: OpenCL support for AMD/ATI Radeon mesa drivers')
+makedepends=('git' 'opencl-headers')
+license=('MIT')
+provides=('hashcat')
+conflicts=('hashcat')
+source=(${pkgname}::git+https://github.com/hashcat/hashcat
+ makefile.patch)
+sha512sums=('SKIP'
+ 'be389cce5f325437b965c755819c09d6b997c534caebd74a947659f8d950e9b3cee365c993928c5522188e53412156eb64218dd844952125de96e7b764716a7d')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" \
+ "$(git describe --tags --abbrev=0|sed -r 's|v?(.+)|\1|'|tr '-' '.')" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ patch -p1 < "${srcdir}/makefile.patch"
+}
+
+build() {
+ cd ${pkgname}
+ make PREFIX=/usr
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ install -Dm 644 docs/license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..7e1730d4734d
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,41 @@
+From 7f8aaf74302816d03fbff62dab5c987d498acdde Mon Sep 17 00:00:00 2001
+From: anthraxx <levente@leventepolyak.net>
+Date: Mon, 4 Jul 2016 21:01:51 +0200
+Subject: [PATCH] extend global CFLAGS and LDFLAGS to aid distro packaging
+
+This preserves globally defined CFLAGS and LDFLAGS and simply
+extends those variables to aid distro based packaging toolchains
+and predefined distro wide defaults like SSP, relro etc.
+---
+ src/Makefile | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 9f11325..cf44590 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -90,7 +90,7 @@ VERSION_TAG := $(shell test -d .git && git describe --tags --dirty=
+ ## Compiler flags
+ ##
+
+-CFLAGS := -pipe -W -Wall -std=c99 -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
++CFLAGS += -pipe -W -Wall -std=c99 -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
+
+ ifndef DEBUG
+ CFLAGS += -O2
+@@ -112,6 +112,7 @@ export MACOSX_DEPLOYMENT_TARGET=10.9
+ CFLAGS_NATIVE := -D_POSIX -DDARWIN
+ CFLAGS_NATIVE += $(CFLAGS)
+ LFLAGS_NATIVE := -lpthread
++LFLAGS_NATIVE += $(LDFLAGS)
+ endif # darwin
+
+ ifeq ($(UNAME),Linux)
+@@ -122,6 +123,7 @@ endif
+ CFLAGS_NATIVE += $(CFLAGS)
+ LFLAGS_NATIVE := -lpthread -ldl
+ CFLAGS_NATIVE += -DHAVE_HWMON
++LFLAGS_NATIVE += $(LDFLAGS)
+ endif # linux
+
+ ##